Premium members don't see ads. Click here to upgrade.

5000 LiPO on stock system

Railroadbrandon

Active Member
Messages
1
Reaction score
0
Arrma RC's
Fury, Granite
ummmm.... Just so you all know, hooking up a 5000LiPO up on your completely stock truck is a bad fatal blow. But it ran like a Syrian Refugee with a free pass into America!
 

MSgt

Well-Known Member
Messages
223
Reaction score
165
Location
Bellevue, Ne
Arrma RC's
Fury, , Raider, Vorteks
Which version do you have? Mega? I've run a couple through my Fury Mega, no problems so far. I do have a 3900kv brushless and a Castle Sidewinder 3 waiting for the original motor to give up the ghost and let the smoke out, though.
 

MSgt

Well-Known Member
Messages
223
Reaction score
165
Location
Bellevue, Ne
Arrma RC's
Fury, , Raider, Vorteks
No. Mines a Mega. The ESC is only good for 2S according to the manual on the top of page 7. The BLX ESC will handle 3S, if you're running a brushless motor.

Edit--Just realized this wasn't aimed at me...oops.
 

FPA4

Well-Known Member
Messages
38
Reaction score
13
Location
Canada
Arrma RC's
Fury, Granite
I dunno, we have three 2S 5000mA/h batteries that share duty in our Granite and Fury, both Megas with the stock 15T brushed motor. We've burned out a couple of motors (they are a consumable after all!) but mostly with the 4600mA/h NiMH from my Granite BLX. The Granite Mega burned out one motor with the LiPos, the Fury has yet to. Breaking in the motors by running them under water for a few minutes seems to have helped.
 

GaryT

Well-Known Member
Messages
39
Reaction score
21
Location
Florida
Arrma RC's
Granite
Trying to decide if I want to replace stock motor (Mega Brushed), or go ahead with replacing with the Sidewinder combo I have. Motor gets hot with 2s 5000 lipo but I keep an eye on it. Also moving back to the 13T pinion from the 18T I had installed helped with heat a little. I regularly spray motor with contact cleaner, but never have broke in by running it in water. Stock on Lipo seems fast enough for me (right now) with how I run it.
Just thought maybe connect the motor fan that came with Castle motor ! May try that if it fits. Need to check where that hooks up.
 

FPA4

Well-Known Member
Messages
38
Reaction score
13
Location
Canada
Arrma RC's
Fury, Granite
Trying to decide if I want to replace stock motor (Mega Brushed), or go ahead with replacing with the Sidewinder combo I have. Motor gets hot with 2s 5000 lipo but I keep an eye on it. Also moving back to the 13T pinion from the 18T I had installed helped with heat a little. I regularly spray motor with contact cleaner, but never have broke in by running it in water. Stock on Lipo seems fast enough for me (right now) with how I run it.
Just thought maybe connect the motor fan that came with Castle motor ! May try that if it fits. Need to check where that hooks up.
Two things, one, the fan is probably not waterproof (if you drive in snow for example) and two, the Arrma motor is surrounded in a way most motors are not, so it is not easy mounting cooling elements. I've got a heatsink I think may work, but I need to cut about half of the clasp that holds it to the motor before it will fit. Will post a pic when I get a chance to do the cut.
 

GaryT

Well-Known Member
Messages
39
Reaction score
21
Location
Florida
Arrma RC's
Granite
You're right. Looked and know way getting that fan on without a lot of hacking. Does not matter though since motor went out on first ten feet of run.

So installed the Castle combo. Well it was sputtering on take off with the 2000 NiMH ( I was being cautious). Figured battery didn't have the umph for it. Put the 2s 5000 lipo in an was not expecting a back flip out of it. Going to try making a change to ESC till I learn to control it better.

Called Arrma and they are sending me new brushed motor. Will have it as back-up or whatever.
 

ArjayGraniteMega2016

Active Member
Messages
28
Reaction score
2
Arrma RC's
Granite, Talion
Trying to decide if I want to replace stock motor (Mega Brushed), or go ahead with replacing with the Sidewinder combo I have. Motor gets hot with 2s 5000 lipo but I keep an eye on it. Also moving back to the 13T pinion from the 18T I had installed helped with heat a little. I regularly spray motor with contact cleaner, but never have broke in by running it in water. Stock on Lipo seems fast enough for me (right now) with how I run it.
Just thought maybe connect the motor fan that came with Castle motor ! May try that if it fits. Need to check where that hooks up.
GaryT- I had installed sidewinder sv3 on my son's Mega no problem with Lipo 5000mah 50C gens ace , it took the entire charge of the battery on a semi soft duty before it went warm not hot.And with the install the castle motor manual says we can run mega up to 3s Lipo.The only issue I had installing the castle motor combo with my sons mega is the holes on the bolt where the motor mounts and the wires of the motor is facing the other side of the motor housing too close. I don't have the luxury of a dremel so I use old school box cutter and did it with a lot of patience..
 
Premium members don't see ads. Click here to upgrade.

Similar threads


Top