Kraton After installing the new stock servo kraton wont go foward/reverse and no power to the servo?

Johnny

Active Member
Messages
15
Reaction score
0
Arrma RC's
Hey guys, after making a claim for my servo warranty it arrived and when i tried to install this is what im getting, seems the esc is weak or something is not connected right. Do i have to reprogram the esc? Please help.
Thanks
 

helizrnew2me

Well-Known Member
Messages
109
Reaction score
38
Location
pa
Arrma RC's
your receiver is flashing like its in binding mode ,did you plug the servo into the "batt" port??
 

Johnny

Active Member
Messages
15
Reaction score
0
Arrma RC's
your receiver is flashing like its in binding mode ,did you plug the servo into the "batt" port??
No, i plugged it into the 1st channel. But, i did tried and binding it too. Im not sure whats going on. Funny this is when i unplug the servo plug, when i apply forward and reverse it applies and when i plug it back in nothing works.
 

Johnny

Active Member
Messages
15
Reaction score
0
Arrma RC's
To be honest, i think i got a bad new arrma servo. The reason i said that is because i pluged the new arrma servo onto my revo and it gave me the same result. The esc was going nuts same as the video above.
So i used the kraton receiver to control revo 3.3 servo and it worked fine. (Video)
 

helizrnew2me

Well-Known Member
Messages
109
Reaction score
38
Location
pa
Arrma RC's
check the polarity on the wiring on the servo plug ,its totally possible it got wired wrong during assembly . beyond that i say you got a bad one
 

Dubbl-A

Well-Known Member
Messages
236
Reaction score
295
Location
PA
Arrma RC's
, Senton
Time for a new (or used) non-arrma servo.
 

Johnny

Active Member
Messages
15
Reaction score
0
Arrma RC's
Would anybody happen to know if this servo is wired correctly to the plug? Looks like i have the version 2 servo. The wires are different colors from my old servo.
 

Attachments

helizrnew2me

Well-Known Member
Messages
109
Reaction score
38
Location
pa
Arrma RC's
just match it up to your others that are plugged in to the receiver .
white is signal wire
red is power
black is ground

ps- compare it to your revo servo wiring
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top