Another Arrma Fury question.

biggman100

Well-Known Member
Messages
764
Reaction score
552
Arrma RC's
  1. Fury
  2. 4x4-Mega
I initially thought this issue was servo related, but, i have since changed the servo that was in it, and the issue didnt go away, so, i tried both Servos in my DHK Hunter, and didnt have any issues, so, now im stumped. The issue is, when i am at a dead stop, or just going slow, and i turn, the truck, for lack of a better way to put it, stutters, almost like it is cogging, and has even completely stopped a couple times, but, at anything from half throttle and faster, it doesn't act up at all. Anyone have any idea as to what it could be? About 3 weeks ago, i used all new parts, although they are the original metal gears, and not the newer composite ones, and rebuilt the diff, and filled it with 30K Traxxas oil (go ahead, im already prepared for the, Traxxas killed it, comments), but, it was fine until maybe a week ago, then it started this stuttering it is doing now. I also replaced all except the motor bearings with rubber shielded ones recently. Could the motor, since i have barely cleaned it all summer, let alone reoiled it, be the issue? It has a Castle Sidewinder ESC and motor (the green can one, i forget the specs at the moment), that has been used hard. I have even had it completely submerged for a few seconds a couple different times (there is a culvert at the end of our road that fills with water, and i just cant resist blasting through it), and, i have also played with the slipper setting, but that was more to tame some of the wheelspin on certain surfaces, but i have been messing with the slipper for about a month now, so i don't think thats it, since its pretty much back to where it was initially. When i took the servo back out, just to make sure it wasnt a battery issue, i put the battery from the Fury in the Hunter, since i only ran it maybe 5 minutes, and, until it hit LVC, it didnt act up at all, so i am at a loss as to what it could be.
 

slick2500

If it ain't broke, you're doing it wrong.
Community Leader
Premium Member
Excellence Award
Build Thread Contributor
Messages
20,297
Reaction score
25,620
Location
Rapid City, SD
Arrma RC's
  1. Kraton EXB
  2. Outcast 6s
  3. Senton 3s
  4. Typhon 3s
I initially thought this issue was servo related, but, i have since changed the servo that was in it, and the issue didnt go away, so, i tried both Servos in my DHK Hunter, and didnt have any issues, so, now im stumped. The issue is, when i am at a dead stop, or just going slow, and i turn, the truck, for lack of a better way to put it, stutters, almost like it is cogging, and has even completely stopped a couple times, but, at anything from half throttle and faster, it doesn't act up at all. Anyone have any idea as to what it could be? About 3 weeks ago, i used all new parts, although they are the original metal gears, and not the newer composite ones, and rebuilt the diff, and filled it with 30K Traxxas oil (go ahead, im already prepared for the, Traxxas killed it, comments), but, it was fine until maybe a week ago, then it started this stuttering it is doing now. I also replaced all except the motor bearings with rubber shielded ones recently. Could the motor, since i have barely cleaned it all summer, let alone reoiled it, be the issue? It has a Castle Sidewinder ESC and motor (the green can one, i forget the specs at the moment), that has been used hard. I have even had it completely submerged for a few seconds a couple different times (there is a culvert at the end of our road that fills with water, and i just cant resist blasting through it), and, i have also played with the slipper setting, but that was more to tame some of the wheelspin on certain surfaces, but i have been messing with the slipper for about a month now, so i don't think thats it, since its pretty much back to where it was initially. When i took the servo back out, just to make sure it wasnt a battery issue, i put the battery from the Fury in the Hunter, since i only ran it maybe 5 minutes, and, until it hit LVC, it didnt act up at all, so i am at a loss as to what it could be.
Not sure what causes it but my Castle Sidewinder 3 did the same thing, it progressively got worse until it just up and died ?
 

biggman100

Well-Known Member
Messages
764
Reaction score
552
Arrma RC's
  1. Fury
  2. 4x4-Mega
Not sure what causes it but my Castle Sidewinder 3 did the same thing, it progressively got worse until it just up and died ?
That will really suck, since, right now i only have a couple of the cheap GoolRC 60A ESC's, and i don't really want to use them in that truck. I have had the Fury at least 2 years now, and who knows how long the guy i got it from had the castle in it. For all i know, it could be quite a few years old.
 

slick2500

If it ain't broke, you're doing it wrong.
Community Leader
Premium Member
Excellence Award
Build Thread Contributor
Messages
20,297
Reaction score
25,620
Location
Rapid City, SD
Arrma RC's
  1. Kraton EXB
  2. Outcast 6s
  3. Senton 3s
  4. Typhon 3s
That will really suck, since, right now i only have a couple of the cheap GoolRC 60A ESC's, and i don't really want to use them in that truck. I have had the Fury at least 2 years now, and who knows how long the guy i got it from had the castle in it. For all i know, it could be quite a few years old.

Yeah I would say it's lived a good life, if you do end up needing a new esc something like this should be fine https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.com/ulk/itm/142385108776
The 10bl60 is a few bucks more https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.com/ulk/itm/223617577650

Then next step up is a Max10 https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.com/ulk/itm/254322809280
 

biggman100

Well-Known Member
Messages
764
Reaction score
552
Arrma RC's
  1. Fury
  2. 4x4-Mega
I have the 10BL50 in my Granite actually. I robbed it from a ARR Hobby King Quanam Vandal i bought, then broke, and parts were on backorder for a long time, and, ever since i have owned the Fury, i have had issues with running it (massive burn outs, shredded tires, that kind of thing, and i have been told the Castle combo is too much for the Fury), so, maybe ill pick up one of those or a 10BL60, and put that motor and ESC in the Granite, and put the 10BL50 and 3650 3250KV combo in the Fury.
 
Top