Outcast Another Stock Servo Issue?

JustAnOutcast

compulsive over-thinker, I think. 🤔
Premium Member
Messages
279
Reaction score
442
I was adjusting droop screws yesterday when I noticed something weird with the front end steering travel…
When manually moving steering (no power) full left position to full right position, the servo will often catch a little past midway to the right. A little extra force and it will then continue to move to the right. Strange (to me) it does this only moving left to right, always at the same spot, and it doesn’t catch every time. I’ve checked for obvious binding with nearby wires but can’t see anything obvious. Removed servo link and rotated servo with the horn and it still catches. Is this normal? Am I missing something? Thanks for your thoughts and advice!
 

utvbroz

Active Member
Messages
31
Reaction score
33
Is this only happening with arms extended all the way or no matter where suspension is?

If all the time, I had an issue on my 3s where the chassis was pushed up a smidge causing the servo horn arm bolt head to hit the chassis a touch turning full right. Used a dremel lightly to resolve.

Edit: Scratch that, the servo is mounted differently on 6. :)
 

JustAnOutcast

compulsive over-thinker, I think. 🤔
Premium Member
Messages
279
Reaction score
442
That's not normal.
You might have a bent gear tooth within the servo..
Wouldn’t a bent gear catch every time?
Is this only happening with arms extended all the way or no matter where suspension is?

If all the time, I had an issue on my 3s where the chassis was pushed up a smidge causing the servo horn arm bolt head to hit the chassis a touch turning full right. Used a dremel lightly to resolve.

Edit: Scratch that, the servo is mounted differently on 6. :)
I’ve looked and looked for obvious clearance issues and don’t see anything. It is possible the servo is mounted incorrectly as I recently replaced, but since it was an exact replacement, there wasn’t any other mods, just drop-in.
 
Last edited:

Tex Koder

2D , 3D Not a problem. I'll take that Challenge.
Lifetime Premium!
Premium Member
ArrmaForum Fan
Build Thread Contributor
Messages
3,819
Reaction score
8,576
Location
Dallas, TX (USA)
Arrma RC's
  1. Granite
  2. Infraction
  3. Kraton 6s
  4. Mojave
  5. Senton 3s
  6. Vendetta
Wouldn’t a bent gear catch every time?

I’ve looked and looked for obvious clearance issues and don’t see anything. It is possible the servo is mounted incorrectly as I recently replaced, but since it was an exact replacement, there wasn’t any other mods, just drop-in.

Depends on how severe the "possible" bent (chipped) tooth is ,I'd imagine.

It's just a hunch on my part ,won't know for sure until you take your servo apart..
 
Last edited:
Top