Battery pop/spark when connected xt90

Mboss

Well-Known Member
Messages
191
Reaction score
143
Arrma RC's
  1. Nero
Any ideas why my battery makes a pop/spark when connecting to nero? Have zippy 5800mah 60c with xt90 connections. Happens when fully charged battery is connected to 2nd plug (doesn't seem to mater which side is plugged in first).
 

chevys10zr2003

Well-Known Member
Lifetime Premium!
Premium Member
ArrmaForum Fan
Excellence Award
Build Thread Contributor
Messages
2,208
Reaction score
1,614
Location
Minnesota, USA
Arrma RC's
  1. Kraton 6s
  2. Senton 6s
  3. Typhon 6s
Any ideas why my battery makes a pop/spark when connecting to nero? Have zippy 5800mah 60c with xt90 connections. Happens when fully charged battery is connected to 2nd plug (doesn't seem to mater which side is plugged in first).
I'm guessing you are just completing the circuit and there is a power surge that jumps the gap when the two connectors are almost touching. They do make anti spark XT90 (XT90-S?) connectors but I have never tried them. You should try connecting 8s with XT150 connectors. Loud pop and large bright spark. Scares the crap out of you the first time you do it. LOL
 

Mboss

Well-Known Member
Messages
191
Reaction score
143
Arrma RC's
  1. Nero
I'm guessing you are just completing the circuit and there is a power surge that jumps the gap when the two connectors are almost touching. They do make anti spark XT90 (XT90-S?) connectors but I have never tried them. You should try connecting 8s with XT150 connectors. Loud pop and large bright spark. Scares the crap out of you the first time you do it. LOL

Thanks for the info...sounds like its nothing to worry about?
 

chevys10zr2003

Well-Known Member
Lifetime Premium!
Premium Member
ArrmaForum Fan
Excellence Award
Build Thread Contributor
Messages
2,208
Reaction score
1,614
Location
Minnesota, USA
Arrma RC's
  1. Kraton 6s
  2. Senton 6s
  3. Typhon 6s
Correct...just as the connection. Aside from that the truck drives great...most stable monster truck Ive ever driven...love this rig...especially at $330:D
From my experience you get that spark over half of the time on 4s and on 6s I have had it 100% of the time myself. The cars that run 2s and 3s I never noticed it on but that's also a lot lower voltage and lower amperage.
 

lonee

Well-Known Member
Messages
576
Reaction score
174
Location
Germany
Arrma RC's
  1. BigRock
You can get XT90 plugs with spark protection. They have a green mark on it.
The left one its with protection and the right one is standard.
IMG_0004.JPG
 

Erex

Active Member
Messages
24
Reaction score
7
Arrma RC's
  1. Nero
The Sparks All In your connection is due to the capacitors wanting to take a charge being that I have installed High amperage car audio systems it does the same same thing, capacitors just want a lot of current. To neutralize the spark use a resistor which is slow charge the capacitors in the eliminate the spark
 

chargh

Well-Known Member
Messages
34
Reaction score
10
Yes the spark is do to the caps charging. I run Castle ESC's in my helies and they spark every time.
According to the Castle web site "the spark is your friend it lets you know that everything is ok". :happy:
 

Stapleton219

Member
Messages
28
Reaction score
6
Arrma RC's
  1. Nero
Mine only sparks if I have turned "on" i.e., cycled, the Esc power switch whilst the batteries are unplugged, no I don't Have switch on while making connection..... If I leave the switch in the off position never cycling while batteries are out, I don't get a spark.
 
Top