Raider Brand new BLX ESC fire on raider blx 1/10

sparky_malone

Well-Known Member
Messages
55
Reaction score
15
Arrma RC's
Raider
Hi,

I bought my self a brand new 1/10 raider blx for xmas thinking it was the new version but was still pleased as it was brand new as described. I went to test it out on boxing day, had it on my dining room table just to check esc settings, steering and all the pre drive checks basically.
I connected a trakpower 2s 6000mah 60c pack fully charged. Turned on the power to the tx then the rx, heard start up beeps then tried the steering, it was ok. Then throttle test......... its just ground and then spun at very low speed then nothing. So i referred to the manual for the esc reset, did so and tried again. had more power but still not alot then it quit again.
I changed packs to a Fluoreon 3s 2200mah 25c turned it all back on and as soon as it finised beeping its bursts into smoke from the esc so i whipped out the battery, best i could see as i was literally pluming smoke.
the wires for the battery were quite hot and of course my esc was fried. The fan cover was melted and the positive wire has been desoldered from the esc and the wire itself was fused hard.
I know the BLX esc can take up to a 3s so not sure why this happened. Ive read that this is a common fault and wonder if any one else has had problems with the blx esc like this?
I had messaged Arrma about this and hopefully they will send me a replacement if this is a factory fault.
I could have been burnt or worse if the lipo caught fire.

What you think to this........???
 

Rooles

Well-Known Member
Messages
101
Reaction score
46
Location
Wichita
Arrma RC's
Granite
Call arrma support. You will get a much faster responce that way. The email system is slow. If the lipo would have caught fire it would have been bad =(
 

sparky_malone

Well-Known Member
Messages
55
Reaction score
15
Arrma RC's
Raider
Call arrma support. You will get a much faster responce that way. The email system is slow. If the lipo would have caught fire it would have been bad =(
Mucho damage I would say.

Thanks for all your fast responses. I called my local Arrma support and explained what happened, was told to send it back for inspection and it will be replaced under warranty if found to be faulty.
Happy days :)

Thanks again
 

justatree

Well-Known Member
Messages
579
Reaction score
214
Arrma RC's
Fury
How's the new esc (if you got it) working for ya?
 

sparky_malone

Well-Known Member
Messages
55
Reaction score
15
Arrma RC's
Raider
So i finally got my new esc and they even sent a new motor too. All is working good so far on the electrics side but i broke a rear hub doing wheelies ;)
Ive come to figure that it may have been the original motor at fault as this time around its sound completely different. even the beeping sounds better so should be cooking now ;)
Thanks Arrma for your excellent support now all thats needed are those mysterious upgrades
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top