Brand new won't work

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
So customer support is closed but I emailed them.

First time trying to run the car and it will only turn left , wheels won't recenter under neutral or positive steering to the right. If you power the truck off, manually recenter the wheels, power on and try to turn right nothing happens. Is there some secret set up I need to do that's not clear in the manual?

Thanks for any input. Pretty frustrated and hope I'm just dumb and missing something obvious.
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
So customer support is closed but I emailed them.

First time trying to run the car and it will only turn left , wheels won't recenter under neutral or positive steering to the right. If you power the truck off, manually recenter the wheels, power on and try to turn right nothing happens. Is there some secret set up I need to do that's not clear in the manual?

Thanks for any input. Pretty frustrated and hope I'm just dumb and missing something obvious.


hmmmmm....pull the servo horn off...servo saver ..all that...down to the bare servo spline shaft and power it up...then try turning remote left and right...just checking to see if the servo hasn't been properly centered during assembly...or if there is a servo issue....

after that...if no luck...reset the reciever and remote...maybe the endpoints are jacked...strange...

will keep thinking on it...
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
Yah that's a sensible plan. I was hoping there was something dumb I hadn't done. Doing all that right out of the box is pretty depressing. And I was so stoked for today!
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
Yah that's a sensible plan. I was hoping there was something dumb I hadn't done. Doing all that right out of the box is pretty depressing. And I was so stoked for today!

well its a start at least...keep moving forward...and when you do get it sorted..be sure to share what you have learned...
 

Julian

Well-Known Member
Messages
629
Reaction score
328
Location
New Rochelle, NY
Arrma RC's
  1. Nero
well its a start at least...keep moving forward...and when you do get it sorted..be sure to share what you have learned...
This the Big Rock? I do remember a post on tightening the servo saver - My hobby guy caught it early in my Nero and tightened it. Hoping you get it sorted out.
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
Well I opened up the bottom of the truck. (Non big rock w diff brain) disconnected the servo from the saver. You can manually use the servo links and the wheels move freely. But when you power on the truck the servo doesn't move at all unless you twist it to a far right turn. Then when you power the car on the servo will center but then still only move left and then get stuck. So I'm pretty sure the problem is in there. Can't think of any sensible way to trouble shoot beyond that without taking the whole gear box out and taking the servo apart, which is not something I feel I should have to do on a never ran truck. I'll be calling arrma support tomorrow and see what they'll do. In the mean time I might just go to my lhs and put in a different servo because it makes me feel like even if I tinkered this one to work, it's sort of lost my faith in its quality already. I just want the beast to be running!
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
Well I opened up the bottom of the truck. (Non big rock w diff brain) disconnected the servo from the saver. You can manually use the servo links and the wheels move freely. But when you power on the truck the servo doesn't move at all unless you twist it to a far right turn. Then when you power the car on the servo will center but then still only move left and then get stuck. So I'm pretty sure the problem is in there. Can't think of any sensible way to trouble shoot beyond that without taking the whole gear box out and taking the servo apart, which is not something I feel I should have to do on a never ran truck. I'll be calling arrma support tomorrow and see what they'll do. In the mean time I might just go to my lhs and put in a different servo because it makes me feel like even if I tinkered this one to work, it's sort of lost my faith in its quality already. I just want the beast to be running!


yeah...looks like you may have found it...and a new servo may do the trick and thus verify that at least it's not a deeper issue...hopefully arrma will make good on it...but all these bad feelings will go away once the beast is going...
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
Oh I know they will. I'm still reeling from how epic it is in person. Online pics and videos don't do the scale and design justice. If a new servo doesn't work I'll just get really butthurt and send it back in to arrma and get a fazon to make me happy.
 

Josh nortz

Well-Known Member
Messages
387
Reaction score
200
Location
Farmington NY
Arrma RC's
  1. Nero
Oh I know they will. I'm still reeling from how epic it is in person. Online pics and videos don't do the scale and design justice. If a new servo doesn't work I'll just get really butthurt and send it back in to arrma and get a fazon to make me happy.
I had a stock nero servo do this to me, it was after a few weeks but it only turned one way and would not turn the other or center when turned on... you will have to send it in but they will replace it.
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
Bummer. I'll probably put in an actual good servo and send the old one back in the mean time and use it as a backup or use it in something else that's smaller.
 

Julian

Well-Known Member
Messages
629
Reaction score
328
Location
New Rochelle, NY
Arrma RC's
  1. Nero
I immediately charge the stock servo on all the 1/8 scales I own. I have only kept the Senton servo as the wheels are much lighter.

Looking at another savox 1270 TG for the Fazon. Just ordered my TBone front bumper and wheeliebar for it as well...I don't trust that Stock one they put on the back.
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
So the truck is up and running! I decided to put on a hitec 7954 sh for the 400 oz torque. This thing is fun! Arrma told me they would replace my servo but I'm thinking about asking them if I could get a body shell instead since I'm going to run the hitec. I'd like to have a basher body and a pretty body. Either that or have them send me some back up screws and body parts or something.
 

PPS-RC

ArrmaForum Vendor
Vendor
Messages
336
Reaction score
858
Location
Cleveland Ohio
Arrma RC's
  1. Kraton 6s
  2. Nero
Nice! That's going to be my first mod. I am honestly suprised that they chose such a weak stock servo. there is no way the factory servo is enough.
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
So the truck is up and running! I decided to put on a hitec 7954 sh for the 400 oz torque. This thing is fun! Arrma told me they would replace my servo but I'm thinking about asking them if I could get a body shell instead since I'm going to run the hitec. I'd like to have a basher body and a pretty body. Either that or have them send me some back up screws and body parts or something.


great news....and as I expected...all the bad feelings gone....ha ha...nero does that...
 

Julian

Well-Known Member
Messages
629
Reaction score
328
Location
New Rochelle, NY
Arrma RC's
  1. Nero
My Arrma Fazon is coming but there's a problem. On the tech notes for the fazon on the tower hobby site. It says clear as day that the fazon has the big rocks HD 14mm UJ links. This was my deal closer on the fazon. I would've ordered the big rock otherwise. Now it's very clear that was not true and the fazon gets the 12mm regular Nero links. I have asked them to send along the parts and if they don't - thinking about just sending back. These links are 49$x 4 so it's a significant difference to make a mistake on. Josh Nortz got a fazon and he is pissed too. Will be calling them. What's annoying is my original plan was to get the big rock and fazon shell.

I am also concerned about all if these HD UJ links breaking which is really confusing on a whole new level...
 

Cr3pitus

Well-Known Member
Military Veteran
Build Thread Contributor
Messages
495
Reaction score
720
Location
Seattle
Arrma RC's
  1. Granite
  2. Kraton 8S
  3. Kraton 6s
  4. Nero
  5. Talion
  6. Typhon 3s
That's interesting. I hope you end up with what you want / are supposed to get. Some of these little parts seem to make a big difference in durability. I haven't had any issues with my shafts or anything like that but I did break a rod end right in half today. I put on the team associated rod ends after that on the cantilevers and I think that will solve that problem. Hopefully you don't have that issue. granted the truck was like 20 feet in the air but I landed it very well on a downward slope so it surprised me that it broke.
 

Mike Honcho

New Member
Messages
1
Reaction score
0
So customer support is closed but I emailed them.

First time trying to run the car and it will only turn left , wheels won't recenter under neutral or positive steering to the right. If you power the truck off, manually recenter the wheels, power on and try to turn right nothing happens. Is there some secret set up I need to do that's not clear in the manual?

Thanks for any input. Pretty frustrated and hope I'm just dumb and missing something obvious.
I went to run my arrma big rock for the first time got a spectrum 3s lipo 5000mah 100c battery and spectrum charger. I walked to a empty parking lot go to turn it on and nothing lol. I'm hoping I'm missing something but idk
 
Top