Can't get TR326 receiver to work

Erstadw

Premium Member!
Premium Member
ArrmaForum Fan
Build Thread Contributor
Messages
331
Reaction score
185
Location
Bloomington, MN
What have you tried? My manual says with the car and transmitter off press bind button with paperclip. While bind button is pressed, power on car. Reciever light should start blinking. Then switch transmitter on and the led on the receiver should stop blinking. If you get that to work you should set your end points. If you have already tried these steps then maybe someone else has an idea.
 

TurboTeg512

Well-Known Member
Messages
53
Reaction score
14
Location
Columbus, OH
Arrma RC's
Fazon
Anyone have any other suggestions? I have no idea what else to try...
theres no such thing as MX trenchers, Its Trenchers or Trenchers X's and those are the X's there wider then normal trenchers. There super fiddlesticking awesome I run them on my notorious.
Should be the same process as described here
This didn't work. I push the link button and nothing happens
 

Yonic

Premium Member!
Premium Member
ArrmaForum Fan
Messages
928
Reaction score
648
Location
Tel Aviv, Israel
Arrma RC's
Senton, Talion, Typhon 6s, Typhon 3s, Voltage
Then something is wrong either on the receiver, or that the ESC doesn't supply power to the receiver, the receiver has a led (on the left/bottom side of the "link" button. that should be green or red.

Try to connect a different receiver to that ESC cable, or connect this receiver to another ESC.. to help you locate the problem.
 

TurboTeg512

Well-Known Member
Messages
53
Reaction score
14
Location
Columbus, OH
Arrma RC's
Fazon
Then something is wrong either on the receiver, or that the ESC doesn't supply power to the receiver, the receiver has a led (on the left/bottom side of the "link" button. that should be green or red.

Try to connect a different receiver to that ESC cable, or connect this receiver to another ESC.. to help you locate the problem.
So I tried another receiver with no luck. I'm thinking it could be my ESC
 
Top