Castle Mamba Micro X2 Calibration w/ Spektrum AVC

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, and others.

MB401

Premium Member!
Premium Member
Active Military
Messages
63
Reaction score
227
Location
Alexandria, VA
Arrma RC's
  1. Granite Grom
  2. Infraction
  3. Typhon 6s
So, I swapped out the Hobby Wing ESC I was running on my Grom, since I wanted to "upgrade" to a Castle ESC. The Hobby Wing was working fine, but I was a big fan of Castle ESCs I used for my helicopter builds, and wanted to try out one of their surface speed controllers. Well, most say "if it isn't broken, don't try to fix it" and I am starting to believe that I should have left the Hobby Wing in the car.

I read the online manual and watched a few You Tube videos on calibration and it looked straight forward and easy. Just tried to calibrate it and it won't take...back to the Google Machine to see what the deal is and it looks like Castle ESCs are not compatible with Spektrum AVC enabled receivers? I am using the SR6100 with the AVC enabled right now, but apparently the AVC technology is not allowing the ESC to detect the throttle end points in my transmitter. I did read a recommendation that you can go in and increase the deadband range of the ESC but I don't want to fiddle with it until I can get some feedback from folks that may have run into the same issue and resolved it. If I can't get it resolved I will either disable the AVC (which I don't want to do since it helps keep that tiny car under control now that I run a brushless system), or ditch the Spektrum ESC altogether. Any solid input would be greatly appreciated!

IMG_9519.jpg
 
Last edited:
Update to the the calibration issue. What made the most sense was to call Castle Creations directly. Assuming I am not the first person to run into this issue, I was hoping they would have an answer. Well, got the answer but it wasn't exactly what I wanted to hear...Castle ESCs are not compatible with Spektrum receivers that have AVC.
Apparently Castle has been aware of this issue and attempted to reach out to Horizon Hobby/Spektrum to figure out a solution but nothing happened.
Given that information, I plugged the Mamba into a Spektrum receiver without AVC (SR315), bound it to my transmitter, and went through the steps to calibrate the ESC without any issues. ESC is now working flawlessly.
 
I have a Typhon grom with a castle esc and spektrum with avc working fine. I didn't calibrate the castle only the spektrum. Go figure. I was gonna try to calibrate the castle after I did the spektrum but it's working so I'm not touching it
 
I have a Typhon grom with a castle esc and spektrum with avc working fine. I didn't calibrate the castle only the spektrum. Go figure. I was gonna try to calibrate the castle after I did the spektrum but it's working so I'm not touching it
Good call. Unfortunately I had to calibrate the Castle since the throttle was not working properly. It easily calibrated when I swapped out the receiver and installed the 315, but since I have ditched my DX6 and I am now using a different brand of transmitter/receiver - and like it much better. My days of being "married" to Spektrum products are done.
 
Oh I hear ya! I was gonna say set up the castle with the 315 receiver, then put the avc receiver in and just do the spektrum tango and see if it works.
 
Back
Top