Diff brain isnt working

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, and others.

Chevyfreak06

Active Member
Messages
70
Reaction score
27
Arrma RC's
  1. Nero
I just got done installing the whole diff brain setup and it's not working. Everything is wired up right abd all the lights work but I'm not hearing and servos function. I got the kit off ebay and everything was taken from a brand new nero. I also tried setting end points but no servos are functioning.
 
I just got done installing the whole diff brain setup and it's not working. Everything is wired up right abd all the lights work but I'm not hearing and servos function. I got the kit off ebay and everything was taken from a brand new nero. I also tried setting end points but no servos are functioning.


hmmm..you try rebinding? ...what remote are you using ?...you did upgrade the remote also?..not sure if non diff remote has enough channels after diff brain upgrade. .
 
hmmm..you try rebinding? ...what remote are you using ?...you did upgrade the remote also?..not sure if non diff remote has enough channels after diff brain upgrade. .

The non diff brain remote is the same as the diff brain remote. I have upgraded two non diff brain Neros and I also got the parts from ebay.

I just got done installing the whole diff brain setup and it's not working. Everything is wired up right abd all the lights work but I'm not hearing and servos function. I got the kit off ebay and everything was taken from a brand new nero. I also tried setting end points but no servos are functioning.
I would double check the wiring. The servo connections are easy enough but the one goes into the third channel and the other goes in line with the throttle if memory serves me correctly.
 
I just got done installing the whole diff brain setup and it's not working. Everything is wired up right abd all the lights work but I'm not hearing and servos function. I got the kit off ebay and everything was taken from a brand new nero. I also tried setting end points but no servos are functioning.

Since it lights up it sounds like your diff brain is plugged into the battery on your receiver. The AUX IN should be plugged into your 3rd channel.
 
Maybe it will be helpful.
At least you need a controller which support 3ch and on the 3rd channel a 4 position switch.
Also a 3ch receiver for sure.
 

Attachments

  • NERO DIFF BRAIN CONFIGURATION 20160704.pdf
    253.3 KB · Views: 84
I got it all figured out had to program everything, but I think I got a bad micro servo. Rear servo worked great then went crazy buzzing and it wont adjust.

Im guessing since I got it off ebay im screwed prolly no warranty. It came out of a brand new nero.
 
mmhmm,
It is sure that the servo has miss function? Do you checked it with a servo tester?
Maybe a reset from the controller will help before you will adjust the diff-brain-board...
Buzzing servos means normally that the servo runs on block or can not run its complete way.
I miss also an servo saver on these servos like Traxxas it has.

Regards,
lonee
 
Old Thread: Hello . There have been no replies in this thread for 90 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.
Back
Top