Kraton DS 3235 Amazon Servo Help

BgSkyRC

Well-Known Member
Messages
37
Reaction score
39
Arrma RC's
  1. Kraton 4s
  2. Outcast 4s
So I got this servo, in some of the reviews people were using this in there Rc trucks no problem. When I steer to the right I get full throw, when I go full left it barely moves, maybe an 1/8" I have my K4V2 with the stock SLT3 Transmitter. I have the steering trim at center and rates all the way up turned to full right. I also had to flip the Reverse switch to get it to go in the correct direction. I am using the Kimbrough 124 saver with this as well, can't figure out why it won't go full left? Any Idea's, did I get a bad servo? What servo did you all get? Thanks in Advance.
https://www.amazon.com/dp/B08KDW4757?ref=ppx_yo2ov_dt_b_product_details&th=1
 

speeding_Infraction

Well-Known Member
Messages
229
Reaction score
227
Location
Seattle
Arrma RC's
  1. Infraction
Reverse the plug going into the reciever, that should fix the reverse switch problem. Then try steering it with just a servo horn or with nothing attached to it. See if it turns both ways with nothing attached
 

BgSkyRC

Well-Known Member
Messages
37
Reaction score
39
Arrma RC's
  1. Kraton 4s
  2. Outcast 4s
Reverse the plug going into the reciever, that should fix the reverse switch problem. Then try steering it with just a servo horn or with nothing attached to it. See if it turns both ways with nothing attached
Thanks I will give it a try and let you know. I did try it with one of the horns that came with it as you mentioned and same results, except I had it plugged in with the brown colored wire on the left which I figured was the ground side.
Servo was centered? Saver centered and aligned?
Yes I did not install it yet, I plugged it in and put the saver on pointing at the 9 o clock position with the servo shaft on my right looking down at the servo.
 

Camaroboy383

Invention is the mother of necessity!
Premium Member
ArrmaForum Fan
Excellence Award
Hospitality Award
Build Thread Contributor
Messages
4,346
Reaction score
7,411
Location
Connecticut
Arrma RC's
  1. 4x4-Mega
  2. Kraton 6s
  3. Outcast 6s
  4. Outcast 4s
  5. Typhon 3s
Thanks I will give it a try and let you know. I did try it with one of the horns that came with it as you mentioned and same results, except I had it plugged in with the brown colored wire on the left which I figured was the ground side.

Yes I did not install it yet, I plugged it in and put the saver on pointing at the 9 o clock position with the servo shaft on my right looking down at the servo.

Servo potentiometer must be bunk, or a physical bind in the gearing... I say warranty it.. brown is ground, ground is always toward the outside of the rx
 

BgSkyRC

Well-Known Member
Messages
37
Reaction score
39
Arrma RC's
  1. Kraton 4s
  2. Outcast 4s
Servo sounds ok moving but definitely has more throw in one direction than the other. I did try switching the plug around but then the servo did not work at all, from left to right the colors are brown, red, orange. I'm guessing there must be something wrong with the pot in it like camaroboy mentioned. I used to fly helicopters before doing cars and never had this issue before, but I was always using name brand quality servos. Well I guess I'll send it back to Amazon then no biggie, my stock servo is still working fine, I just thought I would upgrade it now as it was cheap and prevent future problems. I am going to leave the kimbrough on the stock servo though. Haven't got to run it yet with the new servo saver, weather has been a problem out here. Thanks everyone for the help! (y)

Can someone send a link for the Amazon one you purchased? They probably all come from the same place, or maybe a good one that's not $100 ha ha I don't mind spending money on good parts but I figured these were good from all the posts on them, I guess I just got a bad one, I don't want to order another one and get the same results.:(
 
Last edited:
Top