HELP! New ESC but no throttle

Currently reading:
HELP! New ESC but no throttle

pjmofperk

Well-Known Member
Messages
42
Reaction score
19
Location
Pennsylvania
Arrma RC's
  1. Fury
The latest:
- new ESC, Firma 100
- new receiver for Spectrum SLT3 (receiver is bound)

Still have same problem with a blinking red LED.

Is it the motor or the bullet connections on the motor?

Now my brand new servio doesn’t work. If I turn the wheels to the right the wheels don’t return to center when I release the wheel and they won’t move when I turn the wheel to the left. I had this same problem with the previous ESC that I was trying to get to work.

Does the motor have to he replaced? I’m throwing a lot of money at this thing but I am determined to make it work.

Any ideas? Or should I just trash this thing that I have invested so much time and money in?
 
Last edited:

rotauq

Premium Member!
Premium Member
Build Thread Contributor
Messages
1,841
Reaction score
2,794
Location
The Netherlands
Arrma RC's
  1. Limitless
The latest:
- new ESC, Firma 100
- new receiver for Spectrum SLT3 (receiver is bound)

Still have same problem with a blinking red LED.

Is it the motor or the bullet connections on the motor?

Now my brand new servio doesn’t work. If I turn the wheels to the right the wheels don’t return to center when I release the wheel and they won’t move when I turn the wheel to the left. I had this same problem with the previous ESC that I was trying to get to work.

Does the motor have to he replaced? I’m throwing a lot of money at this thing but I am determined to make it work.

Any ideas? Or should I just trash this thing that I have invested so much time and money in?
Even without a motor the esc-bec should power the receiver and servo. as you describe, the servo is 'on' but doesn't behave as you would expect, right?
 

pjmofperk

Well-Known Member
Messages
42
Reaction score
19
Location
Pennsylvania
Arrma RC's
  1. Fury
Even without a motor the esc-bec should power the receiver and servo. as you describe, the servo is 'on' but doesn't behave as you would expect, right?
Correct. But is was working fine, even with the ESC problems.
Correct. But is was working fine, even with the ESC problems.
It’s a brand new servo, I’ve only had it out for a short test run with original
ESC.
 

rotauq

Premium Member!
Premium Member
Build Thread Contributor
Messages
1,841
Reaction score
2,794
Location
The Netherlands
Arrma RC's
  1. Limitless
Correct. But is was working fine, even with the ESC problems.

It’s a brand new servo, I’ve only had it out for a short test run with original
ESC.
In both cases i've had this behaviour myself it was the servo being bad.

The red blinking on the esc must mean radio CH2 not being within channel neutral range, the new esc doing the same double confirms. If it's not the throttle trim, maybe the pot is worn.
 

pjmofperk

Well-Known Member
Messages
42
Reaction score
19
Location
Pennsylvania
Arrma RC's
  1. Fury
In both cases i've had this behaviour myself it was the servo being bad.

The red blinking on the esc must mean radio CH2 not being within channel neutral range, the new esc doing the same double confirms. If it's not the throttle trim, maybe the pot is worn.
What is the pot?
 

rotauq

Premium Member!
Premium Member
Build Thread Contributor
Messages
1,841
Reaction score
2,794
Location
The Netherlands
Arrma RC's
  1. Limitless
Potentiometer, the thingy in your radio that translates the trigger position an analog signal. It could also be displaced. Have you tried tweaking the throttle trim while the esc is blinking red?
 

pjmofperk

Well-Known Member
Messages
42
Reaction score
19
Location
Pennsylvania
Arrma RC's
  1. Fury
Potentiometer, the thingy in your radio that translates the trigger position an analog signal. It could also be displaced. Have you tried tweaking the throttle trim while the esc is blinking red?
I have tried playing with the throttle trim. I just tried again but nothing. It makes sense that it’s the radio. I have now completely lost steering and it’s a brand new servo.

I ordered a new radio on JennysRC for $23. Fingers crossed.
 

pjmofperk

Well-Known Member
Messages
42
Reaction score
19
Location
Pennsylvania
Arrma RC's
  1. Fury
Heres’ where I am with this:

I bought and bound a new SLT 3 radio
I bought and installed a new ESC
I bought and installed a new servo

I still have the same problem. I use a charged battery, I turn it on and I get the start up tone, then I get a flashing red LED.
Trying to attach a video but no success.
 

Steve38

420+3 RC
Premium Member
Hospitality Award
Build Thread Contributor
Messages
3,079
Reaction score
2,703
Location
Cleveland TN
Arrma RC's
  1. BigRock 4x4
  2. Granite
Heres’ where I am with this:

I bought and bound a new SLT 3 radio
I bought and installed a new ESC
I bought and installed a new servo

I still have the same problem. I use a charged battery, I turn it on and I get the start up tone, then I get a flashing red LED.
Trying to attach a video but no success.
You have to upload to youtube then post the link here.
 
Top