I'm a noob and I'm confused-NERO PROBLEM

Betterwaystodie

Well-Known Member
Messages
2
Reaction score
0
Location
New York
Arrma RC's
  1. Nero
So I just got my Nero and of course like everyone else the tie rod ends broke so I beefed them up. However I have another problem. My bec is somehow set to 6v and I'm loosing steering and having all sorts of throttle problems. To compound the issue anytime I try to reset it back to factory settings via the directions in the manual it won't reset. I can't simply change the variable by beeping through the modes either. Wtf? Any ideas.. Glad I still have my kraton and typhon!
 

Julian

Well-Known Member
Messages
629
Reaction score
333
Location
New Rochelle, NY
Arrma RC's
  1. Nero
So I just got my Nero and of course like everyone else the tie rod ends broke so I beefed them up. However I have another problem. My bec is somehow set to 6v and I'm loosing steering and having all sorts of throttle problems. To compound the issue anytime I try to reset it back to factory settings via the directions in the manual it won't reset. I can't simply change the variable by beeping through the modes either. Wtf? Any ideas.. Glad I still have my kraton and typhon!
Weird but I have a similar problem where the truck just stops for a few seconds and then goes again. I reset the esc by holding the set button while its turned on for 3 seconds - it will beep and after that - no more problems. Its a hobbywing ESC so it DEFINITELY can be reset...
 

Betterwaystodie

Well-Known Member
Messages
2
Reaction score
0
Location
New York
Arrma RC's
  1. Nero
Weird but I have a similar problem where the truck just stops for a few seconds and then goes again. I reset the esc by holding the set button while its turned on for 3 seconds - it will beep and after that - no more problems. Its a hobbywing ESC so it DEFINITELY can be reset...
I think it fried itself. Ordered another. Reset functions aren't responding at all. It's in 6v mode for some reason and I can't get it out. Sucks
 
Top