Lost steering

firstrctruck

Well-Known Member
Messages
88
Reaction score
35
Arrma RC's
  1. Nero
ha ha...typically. ..the servo rod screw comes out...
flip it over...turn it on...turn the wheels...see if you can see if the servo link is disconnected. ...

send pics...and we can give more...
There intact

Here's a pic

Wasnt raging on here either. This sucks
 

Attachments

  • IMG_2896.JPG
    IMG_2896.JPG
    186.2 KB · Views: 24

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
There intact

Here's a pic

Wasnt raging on here either. This sucks
..

ok...so now check tightness of servo saver...and servo wire connections...to make sure they didn't come loose ..

do bench check is steering...meaning...turn on..see if you hear anything when turning the wheel on the transmitter...
 

firstrctruck

Well-Known Member
Messages
88
Reaction score
35
Arrma RC's
  1. Nero
Do I need to take it apart?

..

ok...so now check tightness of servo saver...and servo wire connections...to make sure they didn't come loose ..

do bench check is steering...meaning...turn on..see if you hear anything when turning the wheel on the transmitter...
Nope nothing. The black and red wire ?

I've got throttle and reverse
But no steering
 

Va-jeeper

Well-Known Member
Messages
155
Reaction score
92
Arrma RC's
  1. BigRock
  2. Fazon
  3. Nero
  4. Senton 6s
There intact

Here's a pic

Wasnt raging on here either. This sucks

Is the servo moving when you try and turn it on the transmitter? From you pic, it does look like your servo saver just unscrewed. I would tighten it up. There are two dials. One to tighten your steering and the other one essentially holds it in place. If the servo isn't moving when you are turning on the transmitter then check your wiring...the servo might have unplugged or got pinched. Good luck!
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
Do I need to take it apart?


Nope nothing. The black and red wire ?
Do I need to take it apart?


Nope nothing. The black and red wire ?
...yep...trace back that white red and black wire from the servo to reciever box...

we are just trouble shooting connections...

you may need to move something if you can't verify the entire run...we are just being thorough before saying anything is fried...

get the manual out...pics are very good in the manual ..
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
I got a fluke could you walk me threw it?

So I'd rebinding trans and reciever didn't work...then something is wrong.....hmmm...

do you have another rc to check the servo?..

if throttle control still works we can surely say it's the servo...

are all the other channels working?..meaning I assume this has the diff brain...so do you hear any of the other servos working when you go through the diff lock settings...

starting to seem like the servo may have taken a dive ..

the rebinding process is in the manual...really simple. ..try binding more than once...sometimes it takes a few tries...
 

firstrctruck

Well-Known Member
Messages
88
Reaction score
35
Arrma RC's
  1. Nero
So I'd rebinding trans and reciever didn't work...then something is wrong.....hmmm...

do you have another rc to check the servo?..

if throttle control still works we can surely say it's the servo...

are all the other channels working?..meaning I assume this has the diff brain...so do you hear any of the other servos working when you go through the diff lock settings...

starting to seem like the servo may have taken a dive ..

the rebinding process is in the manual...really simple. ..try binding more than once...sometimes it takes a few tries...
This is the none brain. I'll try bind a few more times. Emailed arrma (disappointed)
Thanks again
 

Afro Samurai

Well-Known Member
Messages
417
Reaction score
200
Location
Digital Underground
Arrma RC's
  1. Nero
This is the none brain. I'll try bind a few more times. Emailed arrma (disappointed)
Thanks again

well don't give up...but yeah that sucks...

alot of times on these ready to run cars ..the servo dual rate isn't properly adjusted...and it only takes a few turns to full lock to fry one...

one more thing to check...open the reciever box and check those connections.....
 

firstrctruck

Well-Known Member
Messages
88
Reaction score
35
Arrma RC's
  1. Nero
well don't give up...but yeah that sucks...

alot of times on these ready to run cars ..the servo dual rate isn't properly adjusted...and it only takes a few turns to full lock to fry one...

one more thing to check...open the reciever box and check those connections.....
What's the recovery box?
 

firstrctruck

Well-Known Member
Messages
88
Reaction score
35
Arrma RC's
  1. Nero
No I appriatte your help. I'm wrenching more than driving. Spending more on parts. Now I'm off the the hobby hanger tomorrow to buy a servo.
 
Top