Register and gain access to Discussions, Reviews, Tech Tips, How to Articles, and much more - on the largest Arrma RC community for RC enthusiasts that covers all aspects of the Arrma-RC brand!

Register Today It's free! This box will disappear once registered!

Mama Monster stuttering

Discussion in 'Talion' started by Ggradtech, Jun 9, 2018.

  1. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I just installed a Mamba Monster X ESC. I tried to throttle test the Talion, and it just stutters like crazy without any acceleration. I checked the Castle Link setting , tried a few different ones, timing, etc. Nothing has changed this. Also, the ESC doesn't "chime" when I first power on the ESC. Any ideas?
     
  2. arrmaracing

    arrmaracing Well-Known Member

    Joined:
    Jan 11, 2018
    Messages:
    269
    Likes Received:
    70
    Location:
    Sydney
    Arrma RC's:
    Fury, Kraton, Outcast, Senton, Talion, Typhon
    Is that the sensored esc and are you running a sensored kotor with it. I heard the mamba stutters alot.
     
  3. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I think the Mamba Monster X is a sensored ESC. I think it should run a sensorless motor without a problem though. Its the stock Talion BLX motor.
     
  4. arrmaracing

    arrmaracing Well-Known Member

    Joined:
    Jan 11, 2018
    Messages:
    269
    Likes Received:
    70
    Location:
    Sydney
    Arrma RC's:
    Fury, Kraton, Outcast, Senton, Talion, Typhon
    Y
    i had a few friends that had mamba with a common problem with stuttering if they don't go full throttle.
     
  5. tjf

    tjf Active Member

    Joined:
    Jan 28, 2017
    Messages:
    7
    Likes Received:
    3
    Arrma RC's:
    Kraton
    I use a mamba monster x and it is awesome make sure it is set to sensorless brushless setting may have to reverse throttle on stock radio and recalibrate esc also make sure battery connectors are soldered properly to esc
     
  6. olds97_lss

    olds97_lss Premium Member!
    Premium Member

    Joined:
    Dec 14, 2016
    Messages:
    277
    Likes Received:
    82
    Did you calibrate the esc to your receiver?

    I had an issue with my MMX with the castle 2200kv sensored motor, but it was due to me not plugging the wires in the right order and using the sensored cable. It would just vibrate angrily when I applied throttle.
     
  7. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I'm thinking maybe the crappy Amazon cheap XT90 connectors are to blame. I can't really get the solder to really stick perfectly. I think maybe I have a cold solder joint. I'm wondering why I get no audible tone when I power up the ESC in the Talion.
     
  8. tjf

    tjf Active Member

    Joined:
    Jan 28, 2017
    Messages:
    7
    Likes Received:
    3
    Arrma RC's:
    Kraton
    if not soldered properly, will definitely cause grief also on startup if set for auto lipo, it should chime the amount of battery cells you are running
     
  9. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    Yeah, at startup I get no tones or chimes at all. I get servo control, but no audio confirmation.
     
  10. olds97_lss

    olds97_lss Premium Member!
    Premium Member

    Joined:
    Dec 14, 2016
    Messages:
    277
    Likes Received:
    82
    Maybe it's in NiMH mode instead of lipo. Would be odd though. Or the LVC is disabled causing it not to do the math on the total voltage.
     
  11. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I hooked up the Castle Link on my PC. Its set on The factory default of LVC 3.2 V and SmartBrushless so it should recognize the cell count of the Lipo.
     
  12. olds97_lss

    olds97_lss Premium Member!
    Premium Member

    Joined:
    Dec 14, 2016
    Messages:
    277
    Likes Received:
    82
    Strange that it doesn't beep when you plug it in. What packs are you using? If I remember right, there is a setting in it that controls current usage. High for really good high C rating packs and medium/low for others.
     
  13. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I called Castle and they think that the ESC is faulty. They are sending me a new one. Great customer service. I've had a lot of Castle stuff and never had one fail.
     
  14. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    I'm an idiot. I checked the solder joints and low a behold...... one of the motor wire ends was not getting a tight connection. Problem solved.
     
  15. olds97_lss

    olds97_lss Premium Member!
    Premium Member

    Joined:
    Dec 14, 2016
    Messages:
    277
    Likes Received:
    82
    Nice. Did you solder it or did it come that way? I think my MMX 2200kv combo came all soldered up for the motor. I just had to put battery connectors on.
     
  16. Ggradtech

    Ggradtech Active Member

    Joined:
    May 14, 2018
    Messages:
    18
    Likes Received:
    4
    Arrma RC's:
    Talion
    No, the MMX (by itself) comes with 3 wires and the bullet connectors. You need to do all the soldering
     
  17. olds97_lss

    olds97_lss Premium Member!
    Premium Member

    Joined:
    Dec 14, 2016
    Messages:
    277
    Likes Received:
    82
    Odd that I don't remember doing that.
     
  18. paul_pl

    paul_pl Well-Known Member

    Joined:
    Apr 19, 2018
    Messages:
    4
    Likes Received:
    1
    Location:
    Poland
    Arrma RC's:
    Kraton
    That's exactly what I've been struggling for a few days until I've discovered one of the motor cable disconnected ;)

     
  • Welcome to Arrma Forum

    Arrma Forum is a Arrma RC fan site that was started to give Arrma RC enthusiasts a place to come together and discuss and share their experiences with the entire Arrma-RC product line, such as the Arrma Kraton, Arrma Talion, and Arrma Granite.

    We welcome all Arrma RC enthusiasts, both new and old, racers and bashers that share a common goal - a willingness to help and learn.
  • Disclaimer