Typhon Need a knowledgable lipo guy for my question

Typhon

Well-Known Member
Messages
97
Reaction score
34
Location
St. Louis
Arrma RC's
I recently purchased 2 Turnigy Lihv batteries and have had some issues with both. 1 simply died on my typhon yesterday after a chassis slap. My venom pro duo lihv charger says reverse polarity now on that battery when i plug the balancing lead in and using a volt meter it reads zero voltage. Hobbyking issued a refund on that one. Sadly they make the buyer eat the shipping cost which is lowsy of them. Now for my question is on my other battery. Being a lihv battery i charge them to 4.35v per cell and after the last 2 charges it seems to stop them just short of that. Though my picture shows the voltage once the charge was finished. 20 min later i then did the battery monitor function on my charger and the (resting?) voltage was 4.26v per 4 cells which already dropped .05ish volts. So Is this normal since i thought it should have a finish voltage of 4.35v?

Forgot the pic but here it is...

20161016_211410.jpg
 

Typhon

Well-Known Member
Messages
97
Reaction score
34
Location
St. Louis
Arrma RC's
Ive since had 2 of these turnigy batteries die on me now and i canceled an order for another. Im currently down to 1 of these remaining but i don't have good hope for it lasting since they die in the same fashion everytime. I contacted. Hobbyking whereas they told me to remove my 5000mah cutoff on my charger and this was preventing a full charge. Also note the blx 185 has a cutoff of 3.2v which is way too low for our lipos. Run an external alarm folks. Since i figured out my problem Id remove this thread if i knew how too.
 
Top