need help with setting up a landing gear on my plane

biggman100

Well-Known Member
Messages
874
Reaction score
761
Arrma RC's
  1. Fury
  2. 4x4-Mega
I just got a 70mm viper and two of my switches are broken on my dx6e but in having trouble getting my gear up and down I have it bound but no luck so far any ideas plane people
Is the landing gear servo connected to either of the radio's broken switches? It could also be that the channel you have the landing gear servo on isnt capable of operating the servo correctly. Is the servo itself bad? I would start by connecting the landing gear servo to a known working channel, even if its the throttle channel, just to verify the servo isnt dead or dying, and then go from there. Worst case, you try different channels until you find one that it works with, or, find out that the servo doesn't work at all.
 

NorthernCrawlerado

Premium Member!
Premium Member
Messages
100
Reaction score
176
Location
Frederick, CO
Arrma RC's
  1. Typhon 3s
Can you go through the menu on the DX6E and assign the gear selection to any switch?

Be advised, I had a DX7S (still do) and everything works on it. I'll send it to you for free. It might be useful to you, all you need to do is put new sticks in the gimbals (I have a couple of Drexel bits there now, which work perfectly). My gear switch is working perfectly.
Also: what receiver are you using? Do you have stabilization? Is it on channel 5?
 
Last edited:

NorthernCrawlerado

Premium Member!
Premium Member
Messages
100
Reaction score
176
Location
Frederick, CO
Arrma RC's
  1. Typhon 3s
I’m using the stock one and it’s on channel 5 and I did all the diagnosis I could I tried everything including plugging it into different ports in and everything
Hmmmm. I'd like you to try to re-bind the plane. You DID get a successful bind, right? Controls were moving, every stick working right, just the gear was not?
 

BashTillBroken

Well-Known Member
Hospitality Award
Build Thread Contributor
Messages
1,876
Reaction score
2,103
Location
Coming around to lap you AGAIN
Arrma RC's
  1. Kraton 6s
  2. Senton 3s
Hmmmm. I'd like you to try to re-bind the plane. You DID get a successful bind, right? Controls were moving, every stick working right, just the gear was not?
Yes everything works but the gear
Do you need pictures of the radio setting to help?
And if so of what
 

BashTillBroken

Well-Known Member
Hospitality Award
Build Thread Contributor
Messages
1,876
Reaction score
2,103
Location
Coming around to lap you AGAIN
Arrma RC's
  1. Kraton 6s
  2. Senton 3s
Everything is plugged in where it should be that’s what weird

image.jpg
 

NorthernCrawlerado

Premium Member!
Premium Member
Messages
100
Reaction score
176
Location
Frederick, CO
Arrma RC's
  1. Typhon 3s
Some bad news, from Spektrum's website:

"Please Note: These transmitters do not support Forward Programming devices: DX6i, DX6G2 (EU Version), DX7, DX7S, DX7SE, DX7G2 (EU Version), DX8, Non-computer transmitters"

My DX7S won't run your AR631.
Do you have it plugged in T A E R G F?
In other words, CH1: Throttle CH2: Aileron CH3: Elevator CH4: Rudder CH5: Gear CH6: Flaps
 

NorthernCrawlerado

Premium Member!
Premium Member
Messages
100
Reaction score
176
Location
Frederick, CO
Arrma RC's
  1. Typhon 3s
Two items of note: You should ensure your radio is updated. 1.) This can be done by going here -

2.) I have never been able to update my Dx7S, for reasons that have never been clear to me. It is not a new radio - it's perhaps 2011 vintage - but it still works absolutely flawlessly without updates with Lemon receivers I have used it with.
 

NorthernCrawlerado

Premium Member!
Premium Member
Messages
100
Reaction score
176
Location
Frederick, CO
Arrma RC's
  1. Typhon 3s
3.) I am concerned that your gear output goes to negative 100% or to zero, but not positive 100%. It should go to both extremes. That could be causing your gear not to deploy.
 
Top