New Fury BLX Question

rcleagle

Active Member
Messages
6
Reaction score
0
Arrma RC's
  1. Fury
  2. Nero
Good evening everyone. I bought my 7 YO son an Arrma Fury BLX for Christmas. I bought him NiMH Batteries for it. I charged his batteries and put it in the car and brand new batteries in the controller. I turned on the remote and car and when we went to drive it the only thing it would do is turn the wheels. It would not go backwards or forwards. Then several minutes later on its own it took off and then stopped and would not move after that. I am new to the hobby so I have no idea what it could be. I have read through the manual to figure it out with no luck. Did I get a bad car? should I contact Arrma since it is brand new? or is this an easy fix. Please help me get this thing going because my 7 YO was very sad that his car would not go and his brothers did. (ps I even tried to only run one cat at a time)
 

Dreadstar

Well-Known Member
Messages
293
Reaction score
146
Location
Glasgow,Scotland
Arrma RC's
  1. Fury
It sounds like you will need to re-bind the radio to the car. Follow the instructions in the manual for this and try the car again. Don't forget,that when you are starting the car,to ALWAYS turn on the transmitter first then the car. When you're finished,the car gets turned off first,then the transmitter.
 

rcleagle

Active Member
Messages
6
Reaction score
0
Arrma RC's
  1. Fury
  2. Nero
Ok I did that. Now it is working for a few seconds and then quits working. It will once again turns the front wheels, but the car will not go forward or backwards I also adjusted the Throttle Trim
 

DBBD

Well-Known Member
Messages
200
Reaction score
98
Arrma RC's
  1. Fury
Take the cover off the receiver and reverse the connections. After you do so, see if the controls are reversed - the steering should control the throttle and the trigger will turn the wheels left and right.

Be careful, because if the symptoms move you may drive off and have no steering.
 

DBBD

Well-Known Member
Messages
200
Reaction score
98
Arrma RC's
  1. Fury
Have you tried different battery packs?

As odd as it may sound, we ran a new Fury today with a battery pack that had just 2 charge cycles on it that caused the car to go a little bit and stop.

I put it on the charger and it charged for about three minutes before the charger indicated a full charge. I put the battery in two different cars and both cars acted the same way, and the cars worked fine with 3 other packs.

Venom is replacing the battery for me.
 
Last edited:

Unusual RC

Premium Member!
Premium Member
Messages
815
Reaction score
311
Location
The Hague, The Netherlands, Europe
Arrma RC's
  1. Fury
  2. Mojave
And?
Any news about the problems with your car?

The difficulty with RC cars is that the problem can be on multiple components.
It is sometimes hard to troubleshoot what is causing the issue.
 

yonzariq

Well-Known Member
Messages
120
Reaction score
59
Location
Rotterdam, The Netherlands
Arrma RC's
  1. Fury
I experienced about the same when I received my Fury BLX, would not react to the TX, stop running, or start running by itself.
Had to re-bind the TX/RX and recalibrate the ESC.
After that it has worked flawless for me
 

Unusual RC

Premium Member!
Premium Member
Messages
815
Reaction score
311
Location
The Hague, The Netherlands, Europe
Arrma RC's
  1. Fury
  2. Mojave
Out of the box the ESC defaults to LiPo so to run NiMH you have to change that setting.

True!
The lipo cut-off is set to 3,2V minimum per cell, which means running a 7 cell ni-mh battery (7 x 1,2V = 8,4V) would be "seen" as a 2 cell (2S) lipo.
Nothing wrong there, but as soon as you give throttle the voltage of the battery-pack will go lower than 3,2V x 2 (cells) = 6,4V.
This will automatically cut-off power instantly!

This is a property of ni-mh cells, even if they are brand new and fully charged! Lipo batteries do not have this voltage drop when power (Amp's) is drained from the battery

The BEC system of your ESC will have no problem supplying the Rx and servo with power. But the 3600kv brushless motor is just too much for a ni-mh battery pack.
I would advice to upgrade to a lipo pack anyway, so much more power!

Nevertheless, when you change the Esc to ni-mh battery setting you will have no issue running this truck.

See your paper manual for how to program this Arrma Esc.
 

rcleagle

Active Member
Messages
6
Reaction score
0
Arrma RC's
  1. Fury
  2. Nero
I contacted Arrma and they tried to trouble shoot it over the phone and they could not figure it out so they had me send it back.
 
Top