New granite

Currently reading:
New granite

Ryan312

Active Member
Messages
8
Reaction score
0
Arrma RC's
  1. Granite
Just got a new granite for Christmas and have only ran it twice. Today when I took it in the yard with leaves it would stop in the middle of the run and not move only wheels would turn. I would have to turn it off then back on to go again then within seconds it would do it again. Any thing i can check or common issues? Everything is still stock
 

NITROMAN2000

Well-Known Member
Messages
142
Reaction score
150
Location
Texas
Arrma RC's
Batteries are drained. Be sure to charge them up again.

Batteries are drained. Be sure to charge them up again.
Also check to see if the esc has a fan, sometimes they get a leaf or piece of straw jamed up and will overheat if the fan can't move.
 

Ryan312

Active Member
Messages
8
Reaction score
0
Arrma RC's
  1. Granite
Batteries are drained. Be sure to charge them up again.


Also check to see if the esc has a fan, sometimes they get a leaf or piece of straw jamed up and will overheat if the fan can't move.
The battery was fully charged before I ran it but I will check to see if there is a fan or any kind of blockage thanks
 

justawfulgamer

Well-Known Member
Messages
33
Reaction score
4
Arrma RC's
  1. Granite
I'm dealing with a similar problem. they are sending me a new esc. I will let you know if that changes anything for me. I wonder if there is a bad batch that shipped or something.
 

SleepyG

Well-Known Member
Messages
12
Reaction score
2
Location
United Kingdom
Arrma RC's
  1. Granite
Are you using Nimh batteries by any chance?

I had a similar problem on my Granite BLX, whereby the truck would run for several seconds before stopping and only the front wheels would move. I think it is something to do with the ESC program mode...I never did get to the bottom of it. I just put in a 2s Lipo and it's ran fine ever since.

Hope you get it sorted.
 

Ryan312

Active Member
Messages
8
Reaction score
0
Arrma RC's
  1. Granite
Yes I thought about getting a hold of the warranty company and seeing what they say and yes it is the stock battery 2000 NiMH battery
 

fury78

Well-Known Member
Messages
4
Reaction score
0
Location
canada
Arrma RC's
  1. Fury
Your esc is probably programed for a lipo battery. Refer to your manual and set it for Nimh battery. Sometimes if you turn the vehicle on before the transmitter this happens or you accidentally hit the set button located near the on off switch on the vehicle. Hope you sort it out.
 

Ryan312

Active Member
Messages
8
Reaction score
0
Arrma RC's
  1. Granite
Update: I took my truck to the hobby shop and they said the esc was bad. They put a new one in and it runs great now
 
Top