No steering before first run?

jaredvahn

Well-Known Member
Messages
12
Reaction score
3
Location
FL
Arrma RC's
  1. Nero
Just unboxed and was getting ready to run my Nero for first time.... but the steering, left/right does not work- no response. Hooked everything and was checking trims and functions and no steering movement results when turning the controller wheel. Steering trim will cause movement on cars wheels but the steering does not go left or right when input is given. Arrgggghhh!

And, the alignment looks a little off in the right front, it looks like the box was opened before I received my 'brand new' Nero. Bummed.
 

lonee

Well-Known Member
Messages
576
Reaction score
175
Location
Germany
Arrma RC's
  1. BigRock
Hi,
first idea.. maybe the servo plug is slipped out of the receiver?
next idea, wrong set to the steering potentiometer?
My potentiometer positions see the pic.
next...
Switch on the car and transmitter, turn first to the right and push the + button below the steering wheel.
If the endpoint are reduced, the wheels will now turn to right. Same with left endpoint.
...what else.... maybe download the ttx300 manual from tactic, in them is written a lot more then in the arrma manual.
If you can read german, I can load it up.

lonee
 

Attachments

  • IMG_0001.JPG
    IMG_0001.JPG
    336 KB · Views: 9

jaredvahn

Well-Known Member
Messages
12
Reaction score
3
Location
FL
Arrma RC's
  1. Nero
Thanks! I will troubleshoot those again and then re-box and send back if no results. I checked all the plugs and items you mentioned but I will try the + sign again with the steering. I did a controller reset, everything. It's probably servo or wiring but this thing should be RTR and I am concerned how unaligned the wheels look too. I think I will be waiting for another one that's without issues.
 

lonee

Well-Known Member
Messages
576
Reaction score
175
Location
Germany
Arrma RC's
  1. BigRock
I am sorry for you. My Big Rock and the the blue Nero of my girlfriend was good out of the box.
In contrast to my Absima Patron.. that car was driven backward because of wrong connection of ESC and motor.
The steering servo died after a few weeks.....
That was one more reason to by my Big Rock.
 

jaredvahn

Well-Known Member
Messages
12
Reaction score
3
Location
FL
Arrma RC's
  1. Nero
Update- I received replacement Nero, opened the box, found the rear bumper was split/ cracked between the mounting screws, so I connected batts, checked the servos and operation were good. I then swapped the cracked bumper to the one that did not have steering - sent it back,...and had a total blast with new one I received.

Super fast and great handling truck. Looking forward to driving it more and learning where and how to optimize it. Definitely an Arrma supporter after seeing it run!
 

72Z15SS

Well-Known Member
Messages
676
Reaction score
889
Location
Pa.
Arrma RC's
  1. Fazon
  2. Nero
  3. Raider
Glad you got it resolved and are having a blast now!
 
Top