No throttle on Outcast

Thread starter #1

Whipplash RC

Active Member
Messages
12
Likes
0
Arrma RC's
Outcast
I was running my Outcast and then all the sudden it stopped running. The esc was blinking green 4 times then would stop and repeat. I have tried a factory reset and it didn’t work. Can anyone tell me what is going on and how to fix it?
 

WTF MIKE

Well-Known Member
Messages
364
Likes
135
Arrma RC's
Outcast
I was running my Outcast and then all the sudden it stopped running. The esc was blinking green 4 times then would stop and repeat. I have tried a factory reset and it didn’t work. Can anyone tell me what is going on and how to fix it?
Try to reset the throttle it worked for me
 

chevys10zr2003

Premium Member!
Premium Member
ArrmaForum Fan
Excellence Award
Messages
1,345
Likes
592
Location
Minnesota, USA
Arrma RC's
Kraton, Senton, Typhon
I was running my Outcast and then all the sudden it stopped running. The esc was blinking green 4 times then would stop and repeat. I have tried a factory reset and it didn’t work. Can anyone tell me what is going on and how to fix it?
How long were you driving it for? Did you still have steering? It sounds like low voltage cutoff to me.
 
Thread starter #8

Whipplash RC

Active Member
Messages
12
Likes
0
Arrma RC's
Outcast
What is the voltage of the batteries and what kind of batteries are you running? What are the temperatures of the motor and ESC?
I was running 2 2s lipos. They are both at 8.15V. The motor and esc weren’t even warm when it happened
 

Happy673

Well-Known Member
Messages
31
Likes
2
Location
California
Arrma RC's
Kraton, Nero, Outcast
Did you ever figure it out ? I just bought the v3 outcast and I'm having problems with it too. Started with the beeping at startup quitting. Now it's just cutting out in the middle of a run. Had a similar experience with the kraton I bought about 2 years ago. I ultimately replaced the esc and motor with a castle mamba monster x esc and castle 2200kv 1515motor. If I have to do this with my outcast I'm not going to be happy.
 
Thread starter #12

Whipplash RC

Active Member
Messages
12
Likes
0
Arrma RC's
Outcast
Did you ever figure it out ? I just bought the v3 outcast and I'm having problems with it too. Started with the beeping at startup quitting. Now it's just cutting out in the middle of a run. Had a similar experience with the kraton I bought about 2 years ago. I ultimately replaced the esc and motor with a castle mamba monster x esc and castle 2200kv 1515motor. If I have to do this with my outcast I'm not going to be happy.
I didn’t. The esc is giving the error code so I thought it was the motor but the motor is fine. I just sent in the esc to Arrma and they should replace it for free.
 

Klaw

Well-Known Member
Messages
5
Likes
1
Arrma RC's
Granite, Outcast
I am also having this problem. It shut down after a snow bash. 4 blinking green lights. It did start up again ran it got one flip out of it and again no throttle and blinking green light. Please tell me theres a better fix then sending it in or buying aftermarket esc
 

Similar threads


Top