Outcast 8s with Max 5 ESC blinking but no audible tones upon startup

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, and others.
Messages
210
Reaction score
195
Location
North of Boston
Arrma RC's
  1. Infraction
  2. Kraton 8S
So I have an outcast 8S fitted with a Max 5 new ESC with the 1250KV motor from the K 8S. Sky fly noble NB4 Radio with Matching receiver.

It's worked in the past and I have not used it for over a month. I tried it today and upon start up the ESE blinks with green lights for the 8 cells that are fitted into the truck but it has no audible tones and only the steering works and when you press forward or reversed It just shakes the gears.

And I personally do not recall anything going Haywire last time I ran this truck.

Is truck has a Primal RC steering servo that's plenty powerful for this truck and is fitted with 2 4s smc 7600 150 C batteries.

It's probably something silly but I figured I'd posted here since everyone knows what they're talking about
 
sounds like you have a loose motor connection somewhere. Maybe a bad solder or something?
 
First, have you checked throttle trim within the transmitter settings; should be centered to 0.

Second, have you tried going through the esc calibration process again?


Third, check for possible receiver problem or bind issue with basic servo test. Esc connector to bind position on receiver, swap steering servo connector to throttle connector position; video at bottom of link:

https://support.hobbywingdirect.com/hc/en-us/articles/360047921474-Servo-works-but-no-Throttle-
 
Good morning. Just wanted to update everyone with the situation with this thing. It seems as though the Spectrum 1250 KV motor I am using in this truck has burnt up for whatever reason. I tested a castle 800 KV motor on the max 5 yesterday and it blinks as it should with the appropriate audible tones coming from the motor counting the cell counts.

So instead of being on the hunt for a 1/5th scale ESC I am now looking for an appropriate motor, probably 1100 KV or even another 800 KV to match the one that's in my kraton 8s.

Should I just go with a hobby wing 1100 KV since it's the same brand or does brand matching not really matter so much
 
Good morning. Just wanted to update everyone with the situation with this thing. It seems as though the Spectrum 1250 KV motor I am using in this truck has burnt up for whatever reason. I tested a castle 800 KV motor on the max 5 yesterday and it blinks as it should with the appropriate audible tones coming from the motor counting the cell counts.

So instead of being on the hunt for a 1/5th scale ESC I am now looking for an appropriate motor, probably 1100 KV or even another 800 KV to match the one that's in my kraton 8s.

Should I just go with a hobby wing 1100 KV since it's the same brand or does brand matching not really matter so much
Brand matching doesn't matter much. You'll probably be happy with the 1100kv hobbywing though. 😎 👍
 
Spectrum 1250 KV motor
I have one that came out of a RTR Outcast 8s...never ran only tested. I pulled it and sold the truck as a slider. It's listed on ebay but I'd sell it to you for $100 shipped 🤷🏻‍♂️
 
Old Thread: Hello . There have been no replies in this thread for 90 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.
Back
Top