Outcast Outcast stearing

CDC45

Well-Known Member
Messages
16
Reaction score
2
Arrma RC's
Anyone have any issues with there shearing mine won't turn tight anymore
 

slpcrf450x

Well-Known Member
Messages
177
Reaction score
87
Arrma RC's
Check the servo saver adjuster nut. If it loosens up it will not turn as well because the servo saver will just flex when you try to make a tight turn. Mine backed off once, and I saw someone else on here that said theirs backed off.
 

Mazing3

Well-Known Member
Messages
84
Reaction score
67
Location
Yardley, PA
Arrma RC's
  1. Nero
Did you mean won't turn right?

I'd check your servo at the same time to see if it's history. Just disco the arm from the ball, hold horn and see if it turns I in both directions via the radio. If it doesn't then you have stripped gears and need to replace those or the servo. It uses brass gears. Better than plastic but still soft.

This is exactly what I had to do with my Outcast yesterday. I went with a Savox 1210sg. No brass gears. Fwiw, I went through a ton of servos with my pos Axial SMT10 Grave digger and this is the one that survived the durability test on that truck.
 

dpricenator

Well-Known Member
Excellence Award
Messages
1,180
Reaction score
1,085
Arrma RC's
Also check your Radio. There is a knob, that will adjust how far the front wheels turn. If you turn it too far you won't turn at all.
 

slpcrf450x

Well-Known Member
Messages
177
Reaction score
87
Arrma RC's
Also check your Radio. There is a knob, that will adjust how far the front wheels turn. If you turn it too far you won't turn at all.
Oh yes, I forgot about the dual rate knob. I have accidentally bumped that before as well.
 

Tsimonster

Member
Messages
29
Reaction score
18
Arrma RC's
I ended up putting blue thread locker on the adjustment collar. It still backed of under some hard crashes, but it does hold better. I started having the problem once I modded my servo mount to be stiffer.
 

Mazing3

Well-Known Member
Messages
84
Reaction score
67
Location
Yardley, PA
Arrma RC's
  1. Nero
Just so I understand what we are even talking about here... your problem is that your servo saver but keeps backing off and then what happens? You lose steering?

If you gave the loctite (blue or red) enough time to dry and it came off again then yeah, I'd say it's stripped. Imagine you did and that was the only thing actually holding it attached.

Just look at the threads and something probably won't look right.
 
Top