Talion Power loss at startup only.

K29er

Active Member
Messages
15
Reaction score
2
Arrma RC's
Talion
Got an updated talion the other day. Large flange around bearings in knuckles and more plastic on wing mount . Love this thing. First two runs on 2x 3s no problem then I switched to one of two new 4s singles I have. Pull the throttle and nothing happens. Then I hear the esc reset. It did this three times before I pulled the battery thinking it was bad. Put 2x 3s back in and zoom away it goes. Put 4s back in and it ran OK but did the no throttle twice more in the 15 min the pack lasted till lvc. Checking voltage one cell was 1.5v lower than the rest!!!! I though the battery was problem. Two days later I tried the same battery after re balancing . 25 minute run no problems. Then I try the other 4s. Same problem.

Ater 5 more 4s packs, 1 a day this is what it does.
It never looses power when moving only when completely stopped, then esc resets. No lights flash once cell count flashes just solid blue/red. If I pull trigger car gives one jerk then nothing. If I pull the trigger super slow it will start moving then it's fine till it comes to a complete stop. Then it won't move. I thought it was a loose wire but if I stay on throttle when crashed upside down I can just flip it over with foot and it keeps going. It has tons of punch once moving and runs like it should, only needing a short run to do good jumps and throttle control is fine in the air. The brakes work. Throttle brake throttle works unless it comes to a complete stop. Once moving throttle control works well enough to do rock crawling.

Sorry for the long post. (Novel).

I tried unplugging the servo and it does the same thing about half the time on the bech with no wheels. I also put my 4pls and receiver in and it's a little better but could just be due to smoother throttle input.
 

BigSplit

Well-Known Member
Messages
194
Reaction score
152
Arrma RC's
Granite, Talion
The fake deans on the stock esc cause all types of problems. Problems like your first set of problems with the esc reseting, also has caused lvc to kick in and out, and the poor connection allowing the bec to still power the servo but esc won't power the motor.

Never seen your exact problem in the last part though. Still, I would try replacing the deans connectors first.
 

K29er

Active Member
Messages
15
Reaction score
2
Arrma RC's
Talion
I was going to replace them but then am I out of warranty if it'd the esc?
 

justatree

Well-Known Member
Messages
579
Reaction score
214
Arrma RC's
Fury
Sheesh, I reckon you got replacement of real deans? Where can I find those? Great planes? @BigSplit
 
Last edited:

K29er

Active Member
Messages
15
Reaction score
2
Arrma RC's
Talion
Don't know. Got the mm2 and 2200kv. Sending esc back to arrma to get checked.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top