Raider Raider BLS Burst into flames

Brakemanbobsmith

Well-Known Member
Messages
60
Reaction score
19
Location
Ohio
Arrma RC's
  1. Raider
  2. Talion
Well found a Raider BLS on Facebook Market Place for a decent price, thought "I have a Talion and Kraton maybe I will buy something in two wheel drive that my wife would be able to run"

I'd seen the Raider and have always been a Buggy fan in real life (built a couple in my time) I thought what the heck so I pulled the trigger an picked up this used Raider.

Picked it up at 7pm that night after meeting with the guy in the local Wal-Mart parking lot after a short check out run (I always meet in public places when buying off the internet)
Took it home sat it on bench and an didn't mess with it till after I got home from work the next day.

My son and grandson came by with his Kraton that he was having steering issues with for me to look at. I have kind of become the RC repair shop for my family LOL

Any way my grandson who owns a Modified Granite was checking out the Raider, so I told him he could take it outside and run it if he wanted to? I put in battery and out the door goes a happy 11 year old.
Having never run the car before myself I followed him outside a couple minutes later.

He had just finished making a couple short passes down the driveway and was setting up to for a speed run as I walked up. He hits the trigger an nothing? looks up at me and say's it won't move Papa ?

I reach down and pick it up to look at it and the ESC just burst into Flames! I blow it out quickly and popped open the battery door and battery drops out and is hanging by the leads at about this point my son walks up and the ESC once again burst into Flames?

My son quickly reaches out and in one swift move grabs and yanks the battery loose I blow flames out again and think well I guess I just wasted that money!

I feel really fortunate that I walked up when I did otherwise this Raider would have been a melted blob of plastic! And I would have had a very upset grandson thinking he just destroyed Papas car.

The guy I bought it from was running it on 2s Lipos and I ask if he had already set ESC up for Lipos then, he said yes it is and he had always run Lipos in it so that's what I was running.

My question is anyone have any Ideas what might have happened or caused this?
And now that I am in need of up-grading the electronics any suggestions on what to buy to replace it with?

Kind of sucks I never even got to pull the trigger on this buggy after getting it home!
Good thing I enjoy working on them LOL
Thanks in advance.

Bob
 

mrbelloso

Premium Member!
Premium Member
Messages
1,120
Reaction score
462
Location
Brisbane, Australia
Arrma RC's
  1. Fury
Try to see if it is still under warranty. If not go to the othrr threads for Electronics and find the ones for the ESC and motors.
 

Brakemanbobsmith

Well-Known Member
Messages
60
Reaction score
19
Location
Ohio
Arrma RC's
  1. Raider
  2. Talion
Try to see if it is still under warranty. If not go to the othrr threads for Electronics and find the ones for the ESC and motors.
Really don't think it is under warranty anymore, older car.
have any suggestions on a replacement ESC or ESC motor combo? Don't want to drop an bunch of money on one but like a middle of the road one?
 

Unusual RC

Premium Member!
Premium Member
Messages
815
Reaction score
317
Location
The Hague, The Netherlands, Europe
Arrma RC's
  1. Fury
  2. Mojave
Had the same with a brand new 120A Tenshock Esc. in my son's Fury.
We ran it for the first time and all was good.
Back home it showed cogging issues from a dead stop into slow forward speed.
Took it indoors, with the 2S lipo still in the car and connected, Esc turned off.
I put it on the kitchen table for 15 minuted until I started to smell something was burning...in flames with in seconds.
just one month out of warranty...:confused:
 

Brakemanbobsmith

Well-Known Member
Messages
60
Reaction score
19
Location
Ohio
Arrma RC's
  1. Raider
  2. Talion
Had the same with a brand new 120A Tenshock Esc. in my son's Fury.
We ran it for the first time and all was good.
Back home it showed cogging issues from a dead stop into slow forward speed.
Took it indoors, with the 2S lipo still in the car and connected, Esc turned off.
I put it on the kitchen table for 15 minuted until I started to smell something was burning...in flames with in seconds.
just one month out of warranty...:confused:
Wow that's scary!
At least mine was outside when it went nuclear.
Think I will always unplug my batteries before bringing them inside from now on!
Thanks
 
Top