ESC continuous blinking green

T-ROY

Fairly New Member
Messages
4
Reaction score
11
I’ve got a 3s Typhon and its been running fine for a while now. After cleaning and putting it up for a few weeks I plugged in a fully charged 3s5000 lipo and I’m getting a steady slow green flash on the esc. I still have steering control but no throttle response. Doesn’t matter what I do with switch A & B it doesn’t change. I’ve tried the fixes others on here and the internet have suggested to fix without success. Most seems to be blinking in a certain series, mine is single flash after another.
‘thanks for any suggestions.
 
Check your motor wire connections for any bare spots or shorts. Make sure the throttle trim is in center position. If all else fails factory reset the esc:
Factory Reset To reset the ESC to factory default settings, connect a battery, turn the transmitter on and then turn the car on. Press and hold the set button for 4 seconds and release. The Red and Green lights will flash simultaneously to show you have reset. Switch the ESC off and factory reset is complete.
Next step would be to pull the motor housing and see if the motor is bricked.
 
Check your motor wire connections for any bare spots or shorts. Make sure the throttle trim is in center position. If all else fails factory reset the esc:
Factory Reset To reset the ESC to factory default settings, connect a battery, turn the transmitter on and then turn the car on. Press and hold the set button for 4 seconds and release. The Red and Green lights will flash simultaneously to show you have reset. Switch the ESC off and factory reset is complete.
Next step would be to pull the motor housing and see if the motor is bricked.
Throttle trim is centered, wires are all good and I’ve tried resetting the esc and the green light never changes.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
 
Last edited:
Throttle trim is centered, wires are all good and I’ve tried resetting the esc and the green light never changes.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
This was helpful for anyone with future issues. Thanks for posting this solution!
 
Throttle trim is centered, wires are all good and I’ve tried resetting the esc and the green light never changes.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
All's well that ends well....

Always feel free to ask for help..... We are all learning
 
Throttle trim is centered, wires are all good and I’ve tried resetting the esc and the green light never changes.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
It would help if I had paid more attention to the battery. Wasted a lot of time that ended up being a battery issue. 6s causes steady green blinking light. Lol! Installed the correct battery and all is good. Sorry for wasting your time with my screw up.
Thanks bro my 3s typhoon was working with 3s but my new 4s would just steer and blink green but now i know for sure its a battery issue!
 
Old Thread: Hello . There have been no replies in this thread for 90 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.
Back
Top