Outcast First bash sesh, not so good

SnotRkt

New Member
Messages
2
Reaction score
1
Arrma RC's
Had my first real session with the Outcast today and it was fun while it lasted. The 3 screws that thread into the aluminum motor mount through the chassis all backed out and then the torque twist from the motor caused the pinion to shred 3 teeth off. Luckily a friend had some pinions in his box and I was able to get it back up and running. shortly after the wing mount gave it up. It was actually kind of fun to run it without the wing and wheelie bar. Overall it wasn't a total bust but I wasn't expecting any failures like that. Wasn't even bashing all that hard. Oh well...

Moral of the story, apparently they didn't threadlock the motor mount screws. Check yours!
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
905
Reaction score
2,216
Location
Roseville, CA
Arrma RC's
Had my first real session with the Outcast today and it was fun while it lasted. The 3 screws that thread into the aluminum motor mount through the chassis all backed out and then the torque twist from the motor caused the pinion to shred 3 teeth off. Luckily a friend had some pinions in his box and I was able to get it back up and running. shortly after the wing mount gave it up. It was actually kind of fun to run it without the wing and wheelie bar. Overall it wasn't a total bust but I wasn't expecting any failures like that. Wasn't even bashing all that hard. Oh well...

Moral of the story, apparently they didn't threadlock the motor mount screws. Check yours!
That's crazy, the factory problem for many of us had been over threadlocking with red instead of blue. Was there any trace of dried locker? If not, someone had a bad day on the assembly line and forgot. Sorry that happened man. I recently had Typhon motor screws come loose at a big BMX track doing hard chassis slaps off big jumps. That was my bad for not rethread locking properly.
 

Buck

Well-Known Member
Messages
205
Reaction score
145
Location
Canada
Arrma RC's
So Rich you use red locker on the motor mount?
Was going to use blue after changing my pinion and doing the center diff shims etc.
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
905
Reaction score
2,216
Location
Roseville, CA
Arrma RC's
So Rich you use red locker on the motor mount?
Was going to use blue after changing my pinion and doing the center diff shims etc.
No I use Loctite blue 242. Use to use Permatex blue gel locker, but it doesn't hold the pinion or input cup grubs for more than a 5-10 bashes. Loctite has been more reliable. I'm pretty generous with it, too.
 
Top