Big Rock Transmitter install help

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, and others.

Harlem

Fairly New Member
Messages
24
Reaction score
16
Hi guys I tried to install my dumborc receiver but failed now when turning car on receiver doesn't light up am presuming av shorted it to be honest I don't really know which is Aux Thr Str so I got wires mixed up anyone got any advice please I am going to just put original receiver back in on my kraton 4s but not sure which connection goes where the Joy's of being a noob lol

20221022_183837.jpg
 
Black wires to the right. So turn each plug around.
That is not a Dumbo receiver in the picture. Post a picture of what you’re trying to do with it.
 
I think you need to 180 the plugs black s/b on the outside. Str is for the servo, Thr is for the esc.
Hi not getting any sign of life in this could it be shorted av orderd the giro one

20221022_191707.jpg

That's it, you want black on the "-" negative and white on the "s" signal. (y)
Hi I am trying to connect this receiver but doesn't light up at all now was thinking av shorted it is that possible thanks
 

Attachments

  • 20221022_191707.jpg
    20221022_191707.jpg
    147 KB · Views: 38
The dumbo is different from others, the top two are throttle and steering. I THINK the top one is throttle so try that first. Then switch them if it doesn’t work.
 
The dumbo is different from others, the top two are throttle and steering. I THINK the top one is throttle so try that first. Then switch them if it doesn’t work.
Hi I am just going to try and connect it back till my good one arrives but having no luck will I have to bind it again do you know added pics of wires thanks for reply

20221022_195246.jpg
 
1 to turn (servo)
2 to
you need to switch your fan and steering connection .... fan goes to AUX and your servo goes to STR
you need to switch your fan and steering connection .... fan goes to AUX and your servo goes to STR

you need to switch your fan and steering connection .... fan goes to AUX and your servo goes to STR
Thanks I will look into this going to do more research before I go in blind but your help is greatly appreciated as I am new to this and really like this arrma forum lots helpful people thanks 👍
 
Watch YouTube videos, read up on it but don’t be worried about asking more questions here. There are a lot of people that like to answer them and help. You won’t be insulted for asking basic questions. I mean you’re first starting out, all of us started somewhere.
 
Thanks I will look into this going to do more research before I go in blind but your help is greatly appreciated as I am new to this and really like this arrma forum lots helpful people thanks 👍
I just came across the same problem the throttle it's #2 for the steering it's #1 (the brown yellow black one. And put the fan on #3 and on my dumborc x4 I just turn on channel 3 manually to have the fan running. The slr300 that the big rock came with had the fan on AUX which was always on. You just have to replicate that.
 
Old Thread: Hello . There have been no replies in this thread for 90 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.
Back
Top