Kraton Anyone ever had your esc do this?

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
It's happened twice now. I will run my Kraton in wet conditions, and sometimes the truck will simply stop moving (servo still works, esc fan still running) I am not sure what the issue is. The esc will just flash green (slowly) After I put the truck away for the night, the esc will usually go back to normal. Any suggestions?

Thanks
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
904
Reaction score
2,118
Location
Roseville, CA
Arrma RC's
It's happened twice now. I will run my Kraton in wet conditions, and sometimes the truck will simply stop moving (servo still works, esc fan still running) I am not sure what the issue is. The esc will just flash green (slowly) After I put the truck away for the night, the esc will usually go back to normal. Any suggestions?

Thanks
Did you calibrate your controller to your ESC? I'm referring to neutral, full throttle, full reverse calibration on page 27 under throttle setup, bottom part of page. This has fixed glitches I was having with both Kraton and Outcast. Also, make sure to always turn controller on before ESC, shutdown ESC then controller. Never had this issue with other rigs or Castle systems, but seems to matter with stock Arrma electronics.
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
I will look into the radio/reviever setup you speak of. Hopefully that will calibrate my radio and my esc... I really don't want to have a faulty esc! But, it is what it is.
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
Did you calibrate your controller to your ESC? I'm referring to neutral, full throttle, full reverse calibration on page 27 under throttle setup, bottom part of page. This has fixed glitches I was having with both Kraton and Outcast. Also, make sure to always turn controller on before ESC, shutdown ESC then controller. Never had this issue with other rigs or Castle systems, but seems to matter with stock Arrma electronics.
So I tried everything and I still can't get it to work... on the phone with Arrma now.
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
904
Reaction score
2,118
Location
Roseville, CA
Arrma RC's
So I tried everything and I still can't get it to work... on the phone with Arrma now.
Sorry bro, hope you get it worked out or replaced free of charge by Arrma. At least it didn't burst into flames like Warbux's did a few weeks back. Let me know the resolution, I'm curious what's up. You're going to have to sneak some bashes in with the Outcast now!!!
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
Sorry bro, hope you get it worked out or replaced free of charge by Arrma. At least it didn't burst into flames like Warbux's did a few weeks back. Let me know the resolution, I'm curious what's up. You're going to have to sneak some bashes in with the Outcast now!!!
I drove the outcast last night... i love it. i might like it more than the kraton!
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
904
Reaction score
2,118
Location
Roseville, CA
Arrma RC's
I drove the outcast last night... i love it. i might like it more than the kraton!
I drove the outcast last night... i love it. i might like it more than the kraton!
Driving it brings me back to my motocross days with balls to the wall squirreliness of course....Lol.
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
Driving it brings me back to my motocross days with balls to the wall squirreliness of course....Lol.
Motocross is pretty intense. Everytime I ride my dirtbikes I bring the RC's as well! Im sending the ESC into Arrma tomorrow. I have never shipped anything before... so Anna is going to help me out haha.
 

Rich Duperbash

Well-Known Member
Excellence Award
Messages
904
Reaction score
2,118
Location
Roseville, CA
Arrma RC's
Motocross is pretty intense. Everytime I ride my dirtbikes I bring the RC's as well! Im sending the ESC into Arrma tomorrow. I have never shipped anything before... so Anna is going to help me out haha.
Sorry you have to deal with that bro. Hopefully it's a quick turnaround and problem gets resolved soon. Version 2 stock electronics have been pretty solid from everything I've heard and experienced personally. Hopefully this was a fluke. Enjoy that Outcast in the meantime!
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
Sorry you have to deal with that bro. Hopefully it's a quick turnaround and problem gets resolved soon. Version 2 stock electronics have been pretty solid from everything I've heard and experienced personally. Hopefully this was a fluke. Enjoy that Outcast in the meantime!
Will do!
 

Cater4anytink

Well-Known Member
Messages
124
Reaction score
43
Location
Birmingham uk
Arrma RC's
I've got the same problem been emailing arrma for about 3 week's,one of there recommendations was that I should try cleaning the on off switch,I'm now waiting to here from the arrma.
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
I've got the same problem been emailing arrma for about 3 week's,one of there recommendations was that I should try cleaning the on off switch,I'm now waiting to here from the arrma.
They sent mine back saying it was not defective.... I re-install and program everything to have it do the same thing 10mins into the first run. Un-plugged and re-plugged the battery and it lasted the rest of the pack. I will let you guy know if it happens again on the next run. Really annoying because my Outcast has never done this... although my Outcast did just strip its steering servo. Really great full for the 2 year warranty!!
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
Just had a new esc in the post,my original one works again for the time being, I ran two 4s packs the other day without a hiccup. My outcast never skipped a beat until after I ran it on 3s with my kid.
Hope you sort it out soon yz
My outcast esc has been great as well.
 

Trickelitrick

Well-Known Member
Messages
244
Reaction score
186
Location
Sweden
Arrma RC's
My esc flashes red and gives power to motor on start but fan not spinning and servo not responding or centering and throttle not responding ....if i connect fan to battery it starts spinning....the swedish support were not very helpful cause i ordered it from modelsport.co.uk so they started arguing with me and they told me to call england, will call their main support tomorrow....
 

yz125ryder

Well-Known Member
Messages
180
Reaction score
74
Arrma RC's
My esc flashes red and gives power to motor on start but fan not spinning and servo not responding or centering and throttle not responding ....if i connect fan to battery it starts spinning....the swedish support were not very helpful cause i ordered it from modelsport.co.uk so they started arguing with me and they told me to call england, will call their main support tomorrow....
im from canada and had to ship it to the US
 
Top