Vorteks ESC blinking when connecting 3S LiPo

Nietrijker

Well-Known Member
Messages
34
Reaction score
12
Location
The Netherlands
Arrma RC's
  1. Granite
  2. Vorteks
Hi all,

My Vorteks ESC is blinking blue when connecting an 11.1V 3S 4000mAh LiPo. A 7.2 NiMH is working fine, as well as a 7.4V 2S 4000mAh LiPo. No issues at all. Just the 11.1V one is giving me issues.

I wonder if 11.1V is actually supported by the BLX ESC I'm having. It's the Arrma BLX80 (390061).

according to the specs it should be supported
link: http://www.arrma-rc.com/power-systems/latest/blx80

please, if anybody knows how to solve this... a big THNX.

-Harold
 

Qwin

Well-Known Member
Messages
56
Reaction score
132
Location
South Africa
Arrma RC's
  1. Talion
Hi all,

My Vorteks ESC is blinking blue when connecting an 11.1V 3S 4000mAh LiPo. A 7.2 NiMH is working fine, as well as a 7.4V 2S 4000mAh LiPo. No issues at all. Just the 11.1V one is giving me issues.

I wonder if 11.1V is actually supported by the BLX ESC I'm having. It's the Arrma BLX80 (390061).

according to the specs it should be supported
link: http://www.arrma-rc.com/power-systems/latest/blx80

please, if anybody knows how to solve this... a big THNX.

-Harold

Hi
I think you need to change the voltage cutoff setting to lipo. See in the picture
Hope this helps

IMG_6457.PNG
 

Nietrijker

Well-Known Member
Messages
34
Reaction score
12
Location
The Netherlands
Arrma RC's
  1. Granite
  2. Vorteks
Amazing... I assumed the gray-fields where factory settings. But I was wrong.

A big THANKS to Qwin !!!
 

Unusual RC

Premium Member!
Premium Member
Messages
815
Reaction score
316
Location
The Hague, The Netherlands, Europe
Arrma RC's
  1. Fury
  2. Mojave
Amazing... I assumed the gray-fields where factory settings. But I was wrong.

They are for some kits of your truck.
Some kits come with a ni-mh as standard, some with a lipo. And some without any battery.
So they change the battery setting accordingly.
As I am not mistaken this "default factory settings" apply to the kits with a lipo and without any battery.

Arrma used to not set the lipo settings in the past, which caused some serious problems as you can imagine.
Indeed they should have put a remark in the manual.
 

Mattyo

Active Member
Messages
2
Reaction score
0
Arrma RC's
  1. Vorteks
Hi all,

My Vorteks ESC is blinking blue when connecting an 11.1V 3S 4000mAh LiPo. A 7.2 NiMH is working fine, as well as a 7.4V 2S 4000mAh LiPo. No issues at all. Just the 11.1V one is giving me issues.

I wonder if 11.1V is actually supported by the BLX ESC I'm having. It's the Arrma BLX80 (390061).

according to the specs it should be supported
link: http://www.arrma-rc.com/power-systems/latest/blx80

please, if anybody knows how to solve this... a big THNX.

-Harold
U can only run up two s 3s burns out the motor thats what mine did
 

Unusual RC

Premium Member!
Premium Member
Messages
815
Reaction score
316
Location
The Hague, The Netherlands, Europe
Arrma RC's
  1. Fury
  2. Mojave
U can only run up two s 3s burns out the motor thats what mine did

Mine is over two years old, and runs perfectly on 3S. My motor is still in good condition!

That said, I never run it full trottle! So it might be just me ;)

Back to the Vortex: Blinking blue means low voltage.
No matter which of the three (3) settings your Esc is set; when you attach a fresh lipo battery of two (2) or three (3) cells (S) it should run.

Some Esc's tell you when you turn them on how many cells the detect. Not the BLX 80 as far as I know. But you should hear sounds coming from the motor.

Make sure your Lipo is fully charged, or check if balanced properly. Otherwise the Esc. might be faulty.

That said, running 3S is completely crazy. I hardly do it since there is no control over the ridiculous amount of power !
 
Top