Register and gain access to Discussions, Reviews, Tech Tips, How to Articles, and much more - on the largest Arrma RC community for RC enthusiasts that covers all aspects of the Arrma-RC brand!

Register Today It's free! This box will disappear once registered!

Vorteks servo problem

Discussion in 'Vorteks' started by adymax, Oct 27, 2015.

Tags:
  1. adymax

    adymax Well-Known Member

    Joined:
    Oct 27, 2015
    Messages:
    4
    Likes Received:
    0
    Arrma RC's:
    Vorteks
    I got a Vorteks for my son last spring and it worked great except some broken part but no big deal issues. About a month ago he went with it and ran it on the baseball field and when I came home from work he said that the RC doesn't work anymore. On testing it the servo was working fine but no throttle. I tried charging batteries just to make sure but only servo worked. Last time I tried the servo seems to turn the wheels just a little but I didn't pay a lot of attention to it.

    So I took it to a hobby shop and a kid there hooked a battery directly to the motor and the motor was dead. He replaced the motor and tried it but the servo wasn't turning the wheels as much as it should, he took the servo cover of to see if there is an obtraction but it was non so he said is the servo because turns juts a little so he hooked a new servo but surprise the new servo didn't work either was turning the same way just a little. So the kid said it is the ESC and I should warranty it and get a new motor too.

    I called ARRMA and they shipped me a motor and ESC and I replaced the ESC but the servo doesn't turn at all. It turns a little if I turn the adjusting pin on the remote but nothing if I do left or right.

    Any idea? Thank You.
     
  2. Walter

    Walter Well-Known Member

    Joined:
    May 19, 2015
    Messages:
    278
    Likes Received:
    203
    Arrma RC's:
    Fury, Granite
    Are you sure you have the server plugged into the receiver properly? (can you send some pics?)

    It's also possible that either the servo or receiver was damaged if the BEC voltage out of the ESC was flakey.
     
  3. adymax

    adymax Well-Known Member

    Joined:
    Oct 27, 2015
    Messages:
    4
    Likes Received:
    0
    Arrma RC's:
    Vorteks
    Here is a video:

     
  4. Walter

    Walter Well-Known Member

    Joined:
    May 19, 2015
    Messages:
    278
    Likes Received:
    203
    Arrma RC's:
    Fury, Granite
    @adymax Things certainly look to be connected properly. Servo and ESC are connected to the receiver in the proper channels and oriented correctly.

    Try switching the steering and throttle connections to the receiver.
    • If the trigger makes the servo move and the front wheels left/right and the steering wheel fails to make the rear wheels spin forward/back then you know the servo is fine and channel one on the receiver is bad. Call and get the receiver replaced under warranty.
    • If the front wheels do not steer with the trigger but the rear wheel power is controlled by the steering wheel on the controller then you know the receiver channel one is good and the servo is faulty.

    Good luck!
     
    #4 Walter, Oct 29, 2015
    Last edited: Oct 31, 2015
    WoodiE likes this.
  5. dijitz

    dijitz Well-Known Member

    Joined:
    Mar 12, 2016
    Messages:
    8
    Likes Received:
    3
    Arrma RC's:
    Vorteks
    I have a sort of similar issue.... should I start a new thread?
    All of a sudden I have no steering. If I adjust steering trim, servo moves to trim steering, but wheel on transmitter does nothing. Tried changing steering servo and throttle servo connection around (as mentioned above) and got no love. Trigger would not move steering servo nor would wheel engage throttle.

    I am totally confused since the steering servo WILL move with steering trim dial.

    Maybe the "steering wheel" has gone bad on the Tx side?
     
  6. adymax

    adymax Well-Known Member

    Joined:
    Oct 27, 2015
    Messages:
    4
    Likes Received:
    0
    Arrma RC's:
    Vorteks
    @dijitz did you get it working? I took mine back to the hobby show and he fix it in 2 min, he played with the dials and got it working. Now I have another problem that's why I'm here.
     
  • Welcome to Arrma Forum

    Arrma Forum is a Arrma RC fan site that was started to give Arrma RC enthusiasts a place to come together and discuss and share their experiences with the entire Arrma-RC product line, such as the Arrma Kraton, Arrma Talion, and Arrma Granite.

    We welcome all Arrma RC enthusiasts, both new and old, racers and bashers that share a common goal - a willingness to help and learn.
  • Disclaimer