Kraton Max8 question

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, and others.

granitebasher88

Active Member
Messages
43
Reaction score
144
Location
Sw fl
Arrma RC's
  1. Granite
  2. Kraton 6s
  3. Mojave
  4. Mojave 4s
  5. Mojave EXB
  6. Senton 3s
  7. Vendetta
  8. Vorteks
Just threw the max8 combo in what is the highest temp with no fan on motor reach?!?!?
Thanks fam!!!!!

image.jpg
 
Just ran first pass with it wasn’t bashing just kind of various speed runs back-and-forth just in the grass and as soon as I ran that pack through it, it was at like 156f.

With that being said, though, I didn’t get a chance to pick up a programmer all I have is my spectrum smart V2, which I have been told it probably doesn’t work on the hobby wing stuff so I haven’t even tried it so tomorrow I’ll pick one up and then mess with some settings. I don’t know if I’m really too impressed with the max eight system, I must be doing something wrong or I don’t have the power all the way up because it definitely doesn’t rip wheelies like the Stock ESC motor. I’m not sure what I’m doing wrong.
 
Just ran first pass with it wasn’t bashing just kind of various speed runs back-and-forth just in the grass and as soon as I ran that pack through it, it was at like 156f.

With that being said, though, I didn’t get a chance to pick up a programmer all I have is my spectrum smart V2, which I have been told it probably doesn’t work on the hobby wing stuff so I haven’t even tried it so tomorrow I’ll pick one up and then mess with some settings. I don’t know if I’m really too impressed with the max eight system, I must be doing something wrong or I don’t have the power all the way up because it definitely doesn’t rip wheelies like the Stock ESC motor. I’m not sure what I’m doing wrong.
If you used same pinion as stock, and you're not getting wheelies, something is drastically wrong. It's a higher kv motor than stock so it might be overdrawing your pack. What pack are you running? My Outcast 6s was significantly faster on the Max8 G2. You have the G2 one right?

What center diff fluid are you running? Maybe the higher torque is engaging center diff? Did you recalibrate throttle when you installed Max8?
 
Yes I am running all stock stuff still just did the combo swap that’s all I mean the car runs and runs decent but with the old motor the car would pretty much do a standing backflip on take off and I’m not getting that not ripping wheelies like it did. And I haven’t changed punch or anything because my spektrum v2 just reads connecting to esc so I take it it is not compatible? Ima have to have one of my buddy’s or lhs look at it I’m also running dx6c remote and I think I have settings right as well on it??!!! I’m lost lol haha

If you used same pinion as stock, and you're not getting wheelies, something is drastically wrong. It's a higher kv motor than stock so it might be overdrawing your pack. What pack are you running? My Outcast 6s was significantly faster on the Max8 G2. You have the G2 one right?

What center diff fluid are you running? Maybe the higher torque is engaging center diff? Did you recalibrate throttle when you installed Max8?
And yes is the g2. I’m also running 2 spektrum 5000 100c 11.1v packs. Which also brings up the problem on the read out on my remote, doesn’t tell me any of the information anymore since changing the ESC like I used to see the voltage I used to be able to see the life of the packs that was left, would be able to see the RPMs all that and now it’s all just blank.
 
Yes I am running all stock stuff still just did the combo swap that’s all I mean the car runs and runs decent but with the old motor the car would pretty much do a standing backflip on take off and I’m not getting that not ripping wheelies like it did. And I haven’t changed punch or anything because my spektrum v2 just reads connecting to esc so I take it it is not compatible? Ima have to have one of my buddy’s or lhs look at it I’m also running dx6c remote and I think I have settings right as well on it??!!! I’m lost lol haha


And yes is the g2. I’m also running 2 spektrum 5000 100c 11.1v packs. Which also brings up the problem on the read out on my remote, doesn’t tell me any of the information anymore since changing the ESC like I used to see the voltage I used to be able to see the life of the packs that was left, would be able to see the RPMs all that and now it’s all just blank.
Try recalibrating the ESC throttle. The instructions are in the manual here.

https://cdn.shopify.com/s/files/1/0...25DUL_EZRUN_MAX8_G2_20220304.pdf?v=1650747513

Screenshot 2024-03-08 at 4.52.02 PM.png
 
I did this this is just hold the power and other buttons down then hitting it after neutral full throttle and full break right?
 
Old Thread: Hello . There have been no replies in this thread for 90 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.
Back
Top